summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfred Wingate <parona@protonmail.com>2024-01-23 10:42:47 +0200
committerSam James <sam@gentoo.org>2024-01-28 14:50:19 +0000
commit17939390efcb504b864531338abf6d9082b1f3fb (patch)
tree2a1f631f059027e7f857f35a92fe79496862e832 /media-tv
parentmedia-tv/kodi: fixup -system-ffmpeg for live (diff)
downloadgentoo-17939390efcb504b864531338abf6d9082b1f3fb.tar.gz
gentoo-17939390efcb504b864531338abf6d9082b1f3fb.tar.bz2
gentoo-17939390efcb504b864531338abf6d9082b1f3fb.zip
media-tv/kodi: fix issue with bundled java packages
* Kodi wasn't properly building them leading to a build error. Unpack and feed this location to the build with -D*_SOURCE_DIR to make sure it works. Closes: https://bugs.gentoo.org/922871 Signed-off-by: Alfred Wingate <parona@protonmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-tv')
-rw-r--r--media-tv/kodi/kodi-9999.ebuild7
1 files changed, 7 insertions, 0 deletions
diff --git a/media-tv/kodi/kodi-9999.ebuild b/media-tv/kodi/kodi-9999.ebuild
index 8725fa3fc6f3..66bd223250ee 100644
--- a/media-tv/kodi/kodi-9999.ebuild
+++ b/media-tv/kodi/kodi-9999.ebuild
@@ -283,6 +283,10 @@ src_unpack() {
else
unpack ${MY_P}.tar.gz
fi
+
+ unpack apache-groovy-binary-${GROOVY_VERSION}.zip
+ unpack commons-lang3-${APACHE_COMMON_LANG_VERSION}-bin.tar.gz
+ unpack commons-text-${APACHE_COMMON_TEXT_VERSION}-bin.tar.gz
}
src_prepare() {
@@ -399,6 +403,9 @@ src_configure() {
-DTARBALL_DIR="${DISTDIR}"
-Dlibdvdnav_URL="${DISTDIR}/libdvdnav-${LIBDVDNAV_VERSION}.tar.gz"
-Dlibdvdread_URL="${DISTDIR}/libdvdread-${LIBDVDREAD_VERSION}.tar.gz"
+ -Dgroovy_SOURCE_DIR="${WORKDIR}/groovy-${GROOVY_VERSION}"
+ -Dapache-commons-lang_SOURCE_DIR="${WORKDIR}/commons-lang3-${APACHE_COMMON_LANG_VERSION}"
+ -Dapache-commons-text_SOURCE_DIR="${WORKDIR}/commons-text-${APACHE_COMMON_TEXT_VERSION}"
)
# Separated to avoid "Manually-specified variables were not used by the project:"