summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-05-05 05:06:16 +0100
committerSam James <sam@gentoo.org>2023-05-05 05:11:29 +0100
commitc6826d4e7e09a7c8a31168ff9b6ecdac46faed49 (patch)
tree5f15a77f746b79b53f71435116f6f1cea8b20a82 /media-sound
parentmedia-libs/alsa-lib: add 1.2.9 (diff)
downloadgentoo-c6826d4e7e09a7c8a31168ff9b6ecdac46faed49.tar.gz
gentoo-c6826d4e7e09a7c8a31168ff9b6ecdac46faed49.tar.bz2
gentoo-c6826d4e7e09a7c8a31168ff9b6ecdac46faed49.zip
media-sound/alsa-utils: add 1.2.9
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/alsa-utils/Manifest1
-rw-r--r--media-sound/alsa-utils/alsa-utils-1.2.9.ebuild91
2 files changed, 92 insertions, 0 deletions
diff --git a/media-sound/alsa-utils/Manifest b/media-sound/alsa-utils/Manifest
index 5a3dd91d9679..1d5a689c3306 100644
--- a/media-sound/alsa-utils/Manifest
+++ b/media-sound/alsa-utils/Manifest
@@ -1 +1,2 @@
DIST alsa-utils-1.2.8.tar.bz2 1560162 BLAKE2B 4b9676957e775be51076b4798dfd384db4eea440c682899024034d3dd593ba24f1d42b8d742c312e041a37f0dbbc12b16635d79f6e6633a3459cc21f80739b5e SHA512 882e6f67467596ed273bf554fcce87d8ef287806bbdabd6c103de4980981f9e2102fb3800c6e8628ee8e86ffb165c1c92f9370c8145f28a6cb7cca563942330b
+DIST alsa-utils-1.2.9.tar.bz2 1598424 BLAKE2B 9d75f63c7ff8b0d7ee835a1ad8fc242dee9b59770b1ad0ff9cd233caf50ac844323fb2ebb8e649f03a0a30a161ec72cba472ac79e390c3f0eb6e2a184d8f576c SHA512 f46e13fd57ed05ee38d3fa655e57b14335ecf0664dbe03275808383d87d28df153a81151e2e9d8786625f09929c567c89e145508a706a70eeb91ac1b11fb2fd4
diff --git a/media-sound/alsa-utils/alsa-utils-1.2.9.ebuild b/media-sound/alsa-utils/alsa-utils-1.2.9.ebuild
new file mode 100644
index 000000000000..67972bd4c49e
--- /dev/null
+++ b/media-sound/alsa-utils/alsa-utils-1.2.9.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit systemd udev
+
+DESCRIPTION="Advanced Linux Sound Architecture Utils (alsactl, alsamixer, etc.)"
+HOMEPAGE="https://alsa-project.org/wiki/Main_Page"
+SRC_URI="https://www.alsa-project.org/files/pub/utils/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0.9"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="bat doc +libsamplerate ieee1394 +ncurses nls selinux"
+
+DEPEND="
+ >=media-libs/alsa-lib-${PV}
+ libsamplerate? ( media-libs/libsamplerate )
+ ieee1394? ( media-libs/libffado )
+ ncurses? ( >=sys-libs/ncurses-5.7-r7:= )
+ bat? ( sci-libs/fftw:= )
+"
+RDEPEND="
+ ${DEPEND}
+ selinux? ( sec-policy/selinux-alsa )
+"
+BDEPEND="
+ virtual/pkgconfig
+ doc? ( app-text/xmlto )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.1.8-missing_header.patch
+)
+
+src_configure() {
+ export ac_cv_lib_ffado_ffado_streaming_init=$(usex ieee1394)
+
+ local myeconfargs=(
+ # --disable-alsaconf because it doesn't work with sys-apps/kmod, bug #456214
+ --disable-alsaconf
+ --disable-maintainer-mode
+ --with-asound-state-dir="${EPREFIX}"/var/lib/alsa
+ --with-systemdsystemunitdir="$(systemd_get_systemunitdir)"
+ --with-udev-rules-dir="${EPREFIX}/$(get_udevdir)"/rules.d
+ $(use_enable bat)
+ $(use_enable libsamplerate alsaloop)
+ $(use_enable ncurses alsamixer)
+ $(use_enable nls)
+ $(usev !doc '--disable-xmlto')
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ dodoc seq/*/README.*
+
+ newinitd "${FILESDIR}"/alsasound.initd-r8 alsasound
+ newconfd "${FILESDIR}"/alsasound.confd-r4 alsasound
+
+ keepdir /var/lib/alsa
+
+ # ALSA lib parser.c:1266:(uc_mgr_scan_master_configs) error: could not
+ # scan directory /usr/share/alsa/ucm: No such file or directory
+ # alsaucm: unable to obtain card list: No such file or directory
+ keepdir /usr/share/alsa/ucm
+
+ find "${ED}" -type f -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ udev_reload
+
+ if [[ -z ${REPLACING_VERSIONS} ]] && ! systemd_is_booted ; then
+ elog
+ elog "To take advantage of the init script, and automate the process of"
+ elog "saving and restoring sound-card mixer levels you should"
+ elog "add alsasound to the boot runlevel. You can do this as"
+ elog "root like so:"
+ elog "# rc-update add alsasound boot"
+ ewarn
+ ewarn "The ALSA core should be built into the kernel or loaded through other"
+ ewarn "means. There is no longer any modular auto(un)loading in alsa-utils."
+ fi
+}
+
+pkg_postrm() {
+ udev_reload
+}