summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorQuentin Retornaz <gentoo@retornaz.com>2024-06-09 02:40:10 +0200
committerJoonas Niilola <juippis@gentoo.org>2024-07-13 10:34:49 +0300
commit86f7a4cf19edfd208b05caac20a885d398a256ab (patch)
tree8a88bc97dfcc2a198d6801bf5e355e577e176124 /media-sound
parentmedia-sound/whipper: fix DEPEND="media-libs/libsndfile[-minimal]" (diff)
downloadgentoo-86f7a4cf19edfd208b05caac20a885d398a256ab.tar.gz
gentoo-86f7a4cf19edfd208b05caac20a885d398a256ab.tar.bz2
gentoo-86f7a4cf19edfd208b05caac20a885d398a256ab.zip
media-sound/whipper: drop old
Signed-off-by: Quentin Retornaz <gentoo@retornaz.com> Closes: https://github.com/gentoo/gentoo/pull/37088 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/whipper/whipper-0.10.0-r1.ebuild65
-rw-r--r--media-sound/whipper/whipper-0.10.0-r2.ebuild56
2 files changed, 0 insertions, 121 deletions
diff --git a/media-sound/whipper/whipper-0.10.0-r1.ebuild b/media-sound/whipper/whipper-0.10.0-r1.ebuild
deleted file mode 100644
index 48549099d453..000000000000
--- a/media-sound/whipper/whipper-0.10.0-r1.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DISTUTILS_USE_PEP517="setuptools"
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit distutils-r1
-
-DESCRIPTION="A Python CD-DA ripper preferring accuracy over speed (forked from morituri)"
-HOMEPAGE="https://github.com/whipper-team/whipper"
-SRC_URI="https://github.com/whipper-team/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-3+"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-DEPEND="
- media-libs/libsndfile:=
-"
-# bug https://bugs.gentoo.org/923339
-# upstream https://github.com/whipper-team/whipper/issues/605
-# upstream https://github.com/whipper-team/whipper/issues/606
-RDEPEND="
- ${DEPEND}
- app-cdr/cdrdao
- >=dev-libs/libcdio-paranoia-0.94_p2
- dev-python/musicbrainzngs[${PYTHON_USEDEP}]
- >=dev-python/pycdio-2.1.0[${PYTHON_USEDEP}]
- dev-python/pygobject:3[${PYTHON_USEDEP}]
- dev-python/discid[${PYTHON_USEDEP}]
- <dev-python/ruamel-yaml-0.18.0[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
- media-libs/mutagen[${PYTHON_USEDEP}]
- media-sound/sox[flac]
-"
-BDEPEND="
- dev-python/setuptools-scm[${PYTHON_USEDEP}]
- test? (
- dev-python/twisted[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests unittest
-
-PATCHES=(
- "${FILESDIR}/${PN}-0.7.0-cdparanoia-name-fix.patch"
-)
-
-python_prepare_all() {
- # accurip test totally depends on network access
- rm "${PN}"/test/test_common_accurip.py || die
-
- # Test fails with
- # Log [82 chars]28Z\n\nRipping phase information:\n Drive: HL[2290 chars]31\n
- # !=
- # Log [82 chars]28Z\nRipping phase information:\n Drive: HL-D[2274 chars]31\n
- # assertion. TODO: fix test.
- rm "${PN}"/test/test_result_logger.py || die
-
- export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
-
- distutils-r1_python_prepare_all
-}
diff --git a/media-sound/whipper/whipper-0.10.0-r2.ebuild b/media-sound/whipper/whipper-0.10.0-r2.ebuild
deleted file mode 100644
index 4458574acf2f..000000000000
--- a/media-sound/whipper/whipper-0.10.0-r2.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DISTUTILS_USE_PEP517="setuptools"
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit distutils-r1
-
-DESCRIPTION="A Python CD-DA ripper preferring accuracy over speed (forked from morituri)"
-HOMEPAGE="https://github.com/whipper-team/whipper"
-SRC_URI="https://github.com/whipper-team/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-3+"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-DEPEND="
- media-libs/libsndfile:=
-"
-RDEPEND="
- ${DEPEND}
- app-cdr/cdrdao
- >=dev-libs/libcdio-paranoia-0.94_p2
- dev-python/musicbrainzngs[${PYTHON_USEDEP}]
- >=dev-python/pycdio-2.1.0[${PYTHON_USEDEP}]
- dev-python/pygobject:3[${PYTHON_USEDEP}]
- dev-python/discid[${PYTHON_USEDEP}]
- dev-python/ruamel-yaml[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
- media-libs/mutagen[${PYTHON_USEDEP}]
- media-sound/sox[flac]
-"
-BDEPEND="
- dev-python/setuptools-scm[${PYTHON_USEDEP}]
- test? (
- dev-python/twisted[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests unittest
-
-PATCHES=(
- "${FILESDIR}/${PN}-0.7.0-cdparanoia-name-fix.patch"
- "${FILESDIR}/${PN}-0.10.0-ruamel-yaml.patch"
-)
-
-python_prepare_all() {
- # accurip test totally depends on network access
- rm "${PN}"/test/test_common_accurip.py || die
-
- export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
-
- distutils-r1_python_prepare_all
-}