summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2022-11-14 15:59:45 +0100
committerAlexis Ballier <aballier@gentoo.org>2022-11-14 16:24:34 +0100
commit18146684a8bb0ebefed31b5bc95edf3d51d9d27a (patch)
treeea7e964f3f9a129bbc76f99ccf2f460ccdbe9e72 /media-sound
parentx11-terms/lilyterm: Delete (diff)
downloadgentoo-18146684a8bb0ebefed31b5bc95edf3d51d9d27a.tar.gz
gentoo-18146684a8bb0ebefed31b5bc95edf3d51d9d27a.tar.bz2
gentoo-18146684a8bb0ebefed31b5bc95edf3d51d9d27a.zip
media-sound/qsynth: bump to 0.9.8
Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/qsynth/Manifest1
-rw-r--r--media-sound/qsynth/qsynth-0.9.8.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/media-sound/qsynth/Manifest b/media-sound/qsynth/Manifest
index f9e8a2fa6926..c08801f89441 100644
--- a/media-sound/qsynth/Manifest
+++ b/media-sound/qsynth/Manifest
@@ -1 +1,2 @@
DIST qsynth-0.9.7.tar.gz 335564 BLAKE2B 7f74aebf0c635943e64be636035f86bb74e94514f97f199046cebed37675503c15225f626aba9bc862d07b13d941bb26bc3d3550f0f2c0dc32a8ed6db6c7f029 SHA512 1df8b96423a44d2a3db47417867319cea5df941e4e17e7b04c5b9c3839fff4c7d77cbc4a1ba86a2c17f5bbe13aefa59fc46a8769ecb1a2590c1f4c6c28ae6081
+DIST qsynth-0.9.8.tar.gz 333010 BLAKE2B 60433afaccc6a1378b9799316bd8d4a0cbe3592059788feacf8564e6ee659ea61904358378d3307a12e706c8aeb70a51546063fc7f766091ea784f7e01bb780a SHA512 f193dcbce0b92e25d5310c5f6d78a6360a8a6f089efceae55b7a425a823d418618ee2fd0debca6b9e4793e988b92f2dd8c2f32812f21224e8e566ab15d4d5e64
diff --git a/media-sound/qsynth/qsynth-0.9.8.ebuild b/media-sound/qsynth/qsynth-0.9.8.ebuild
new file mode 100644
index 000000000000..802d146a7511
--- /dev/null
+++ b/media-sound/qsynth/qsynth-0.9.8.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake desktop xdg
+
+DESCRIPTION="Qt application to control FluidSynth"
+HOMEPAGE="https://qsynth.sourceforge.io/"
+
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://git.code.sf.net/p/qsynth/code"
+ inherit git-r3
+else
+ SRC_URI="mirror://sourceforge/qsynth/${P}.tar.gz"
+ KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="+alsa debug jack pulseaudio"
+
+REQUIRED_USE="|| ( alsa jack pulseaudio )"
+
+BDEPEND="
+ dev-qt/linguist-tools:5
+"
+DEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtwidgets:5
+ media-sound/fluidsynth:=[jack?,alsa?,pulseaudio?]
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${PN}-0.9.1-cmake-no-git-version.patch" )
+
+src_prepare() {
+ cmake_src_prepare
+
+ sed -e "/^find_package.*QT/s/Qt6 //" -i CMakeLists.txt || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCONFIG_DEBUG=$(usex debug 1 0)
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+
+ # The desktop file is invalid, and we also change the command
+ # depending on useflags
+ rm "${D}/usr/share/applications/org.rncbc.qsynth.desktop" || die
+
+ local cmd
+ if use jack; then
+ cmd="qsynth"
+ elif use pulseaudio; then
+ cmd="qsynth -a pulseaudio"
+ elif use alsa; then
+ cmd="qsynth -a alsa"
+ else
+ cmd="qsynth -a oss"
+ fi
+
+ make_desktop_entry "${cmd}" Qsynth qsynth
+}