summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2023-03-29 08:50:57 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2023-03-29 08:51:14 +0200
commit11e7eb2f45dc2040dbc89ca768be8008df03514b (patch)
tree6f13c2110c6a91f10bf9aa84a0fe5f0b1f4d3ea0 /media-sound
parentwww-apps/nanoc: fix line length warning (diff)
downloadgentoo-11e7eb2f45dc2040dbc89ca768be8008df03514b.tar.gz
gentoo-11e7eb2f45dc2040dbc89ca768be8008df03514b.tar.bz2
gentoo-11e7eb2f45dc2040dbc89ca768be8008df03514b.zip
media-sound/frescobaldi: bump to 3.3.0
Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/frescobaldi/Manifest1
-rw-r--r--media-sound/frescobaldi/frescobaldi-3.3.0.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/media-sound/frescobaldi/Manifest b/media-sound/frescobaldi/Manifest
index 9429bf758128..4f095d46b8c0 100644
--- a/media-sound/frescobaldi/Manifest
+++ b/media-sound/frescobaldi/Manifest
@@ -1 +1,2 @@
DIST frescobaldi-3.2.tar.gz 6696111 BLAKE2B e74a8c3a59c6dc5187538785bc5971dd996cf897c6428ff510775bad58aa4c04dd69b91f3821b9c868a3e7f13b6cae6f76814188de2620542959039e768c9be0 SHA512 403ae6cfe145595fef0ffe06ce4fd595a0417201b19e5f2315944b45cdcec50592296424f2bf2c7e3eccbe3dbeb9ff5bfc4aa7813241d8168bc057e7bf5539b3
+DIST frescobaldi-3.3.0.tar.gz 9196964 BLAKE2B 52e0c39e3a9fd70f5e450dd45cd0c0c0683b8c0af243d568e765f351500da138c0e527a579245c3d72e628d6a940003c62e1d70b6cff8ecb55d7214b7def8093 SHA512 0dc851cb2ab001f366d20d3c27159087a643cbb5661cc7388b9ec5209c03d4d47dc9114f378dab0562a1a4cb84c2a67eddd8b1981ceaa057e5ac79f8c277ad05
diff --git a/media-sound/frescobaldi/frescobaldi-3.3.0.ebuild b/media-sound/frescobaldi/frescobaldi-3.3.0.ebuild
new file mode 100644
index 000000000000..7db5046cd3b0
--- /dev/null
+++ b/media-sound/frescobaldi/frescobaldi-3.3.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..10} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1 xdg
+
+DESCRIPTION="A LilyPond sheet music text editor"
+HOMEPAGE="https://www.frescobaldi.org/"
+SRC_URI="https://github.com/frescobaldi/frescobaldi/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ dev-python/PyQt5[gui,network,printsupport,svg,widgets,${PYTHON_USEDEP}]
+ dev-python/PyQtWebEngine[${PYTHON_USEDEP}]
+ dev-python/python-ly[${PYTHON_USEDEP}]
+ dev-python/python-poppler-qt5[${PYTHON_USEDEP}]
+ dev-python/qpageview[${PYTHON_USEDEP}]
+ media-sound/lilypond"
+RDEPEND="${DEPEND}
+ x11-themes/tango-icon-theme
+"
+
+python_prepare_all() {
+ rm -r frescobaldi_app/icons/Tango || die "failed to remove tango icon theme"
+ distutils-r1_python_prepare_all
+ emake -C i18n
+ emake -C linux
+}