summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/rplay
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/rplay')
-rw-r--r--media-sound/rplay/Manifest2
-rw-r--r--media-sound/rplay/files/rplay-3.3.2-built-in_function_exit.patch20
-rw-r--r--media-sound/rplay/metadata.xml12
-rw-r--r--media-sound/rplay/rplay-3.3.2-r1.ebuild42
4 files changed, 76 insertions, 0 deletions
diff --git a/media-sound/rplay/Manifest b/media-sound/rplay/Manifest
new file mode 100644
index 000000000000..ba37455eb237
--- /dev/null
+++ b/media-sound/rplay/Manifest
@@ -0,0 +1,2 @@
+DIST rplay-3.3.2.tar.gz 480015 SHA256 74265153457a44e1e2f0fa38c59c9b12ea5b684db2c83eb055184f86db81fdd8
+DIST rplay_3.3.2-12.diff.gz 25322 SHA256 9f38ea87379e915ffb3fb338baf454f7ce2cbc605616c27b82df25f708220626
diff --git a/media-sound/rplay/files/rplay-3.3.2-built-in_function_exit.patch b/media-sound/rplay/files/rplay-3.3.2-built-in_function_exit.patch
new file mode 100644
index 000000000000..e7b59dfeba88
--- /dev/null
+++ b/media-sound/rplay/files/rplay-3.3.2-built-in_function_exit.patch
@@ -0,0 +1,20 @@
+--- adpcm/decode.c
++++ adpcm/decode.c
+@@ -6,6 +6,7 @@
+ * Usage : decode [-3|4|5] [-a|u|l] < infile > outfile
+ */
+ #include <stdio.h>
++#include <stdlib.h>
+ #include "g72x.h"
+
+
+--- adpcm/encode.c
++++ adpcm/encode.c
+@@ -6,6 +6,7 @@
+ * Usage : encode [-3|4|5] [-a|u|l] < infile > outfile
+ */
+ #include <stdio.h>
++#include <stdlib.h>
+ #include "g72x.h"
+
+
diff --git a/media-sound/rplay/metadata.xml b/media-sound/rplay/metadata.xml
new file mode 100644
index 000000000000..4acb13994e2f
--- /dev/null
+++ b/media-sound/rplay/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sound</herd>
+ <longdescription lang="en">
+ rplay is a flexible network audio system that allows sounds to be played
+ to and from local and remote Unix systems. Sounds can be played with or
+ without sending audio data over the network using either UDP or TCP.
+ rplay audio servers can be configured to share sound files with each
+ other.
+ </longdescription>
+</pkgmetadata>
diff --git a/media-sound/rplay/rplay-3.3.2-r1.ebuild b/media-sound/rplay/rplay-3.3.2-r1.ebuild
new file mode 100644
index 000000000000..8ba1e6fba0b1
--- /dev/null
+++ b/media-sound/rplay/rplay-3.3.2-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit autotools eutils multilib user
+
+DESCRIPTION="Play sounds on remote Unix systems, without sending audio data over the network"
+HOMEPAGE="http://rplay.doit.org/"
+SRC_URI="http://rplay.doit.org/dist/${P}.tar.gz mirror://debian/pool/main/r/rplay/rplay_${PV}-12.diff.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 s390 sparc x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="media-sound/gsm"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ enewgroup rplayd ""
+ enewuser rplayd "" "" "" rplayd
+}
+
+src_unpack() {
+ unpack ${A}
+ epatch "${WORKDIR}"/rplay_${PV}-12.diff
+ cd "${S}"
+ EPATCH_FORCE="yes" EPATCH_SUFFIX="dpatch" epatch debian/patches
+ epatch "${FILESDIR}"/${P}-built-in_function_exit.patch
+ eautoreconf
+}
+
+src_compile() {
+ econf \
+ --enable-rplayd-user=rplayd \
+ --enable-rplayd-group=rplayd
+ emake || die
+}
+
+src_install() {
+ einstall || die
+}