summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-08-08 23:07:22 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-08-09 10:31:48 +0200
commit475af8cdd2c4885724e71a10e8f9f658c33a232a (patch)
tree5530bd5b2a65cd3b95d3a06c2f24cd08c128522b /media-sound/qastools/qastools-0.23.0.ebuild
parentkde-misc/tellico: 3.3.2 version bump (diff)
downloadgentoo-475af8cdd2c4885724e71a10e8f9f658c33a232a.tar.gz
gentoo-475af8cdd2c4885724e71a10e8f9f658c33a232a.tar.bz2
gentoo-475af8cdd2c4885724e71a10e8f9f658c33a232a.zip
media-sound/qastools: 0.23.0 version bump
Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-sound/qastools/qastools-0.23.0.ebuild')
-rw-r--r--media-sound/qastools/qastools-0.23.0.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/media-sound/qastools/qastools-0.23.0.ebuild b/media-sound/qastools/qastools-0.23.0.ebuild
new file mode 100644
index 000000000000..9f055f434b6b
--- /dev/null
+++ b/media-sound/qastools/qastools-0.23.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Qt5 GUI ALSA tools: mixer, configuration browser"
+HOMEPAGE="https://gitlab.com/sebholt/qastools"
+SRC_URI="https://gitlab.com/sebholt/${PN}/-/archive/v${PV}/${PN}-v${PV}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+BDEPEND="
+ dev-qt/linguist-tools:5
+"
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ media-libs/alsa-lib
+ virtual/libudev:=
+"
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}/${P}-nomancompress.patch" )
+
+S="${WORKDIR}"/${PN}-v${PV}
+
+src_configure() {
+ local mycmakeargs=(
+ -DSKIP_LICENSE_INSTALL=ON
+ -DCMAKE_DISABLE_FIND_PACKAGE_UnixCommands=ON
+ )
+ cmake_src_configure
+}