summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-04-27 10:02:54 -0400
committerMatt Turner <mattst88@gentoo.org>2021-04-27 10:03:56 -0400
commitaac513b177a376c8eb245e408a65d80919c554fa (patch)
tree37cc85f1384669d9d2965dbf7bbd53a85c349486 /media-sound/guitarix
parentnet-wireless/broadcom-sta: make CONFIG_LIB80211 optional (diff)
downloadgentoo-aac513b177a376c8eb245e408a65d80919c554fa.tar.gz
gentoo-aac513b177a376c8eb245e408a65d80919c554fa.tar.bz2
gentoo-aac513b177a376c8eb245e408a65d80919c554fa.zip
media-sound/guitarix: Fix build with glib-2.68
Closes: https://bugs.gentoo.org/784395 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'media-sound/guitarix')
-rw-r--r--media-sound/guitarix/files/guitarix-0.42.1-fix-build-with-glib-2.68.patch13
-rw-r--r--media-sound/guitarix/guitarix-0.42.1.ebuild1
2 files changed, 14 insertions, 0 deletions
diff --git a/media-sound/guitarix/files/guitarix-0.42.1-fix-build-with-glib-2.68.patch b/media-sound/guitarix/files/guitarix-0.42.1-fix-build-with-glib-2.68.patch
new file mode 100644
index 000000000000..345f5e9a0aab
--- /dev/null
+++ b/media-sound/guitarix/files/guitarix-0.42.1-fix-build-with-glib-2.68.patch
@@ -0,0 +1,13 @@
+diff --git a/src/headers/gx_system.h b/src/headers/gx_system.h
+index d334ecfc..88d97567 100644
+--- a/src/headers/gx_system.h
++++ b/src/headers/gx_system.h
+@@ -132,7 +132,7 @@ inline T *atomic_get(T*& p) {
+
+ template <class T>
+ inline bool atomic_compare_and_exchange(T **p, T *oldv, T *newv) {
+- return g_atomic_pointer_compare_and_exchange(reinterpret_cast<void* volatile*>(p), static_cast<void*>(oldv), newv);
++ return g_atomic_pointer_compare_and_exchange(reinterpret_cast<void**>(p), static_cast<void*>(oldv), newv);
+ }
+
+
diff --git a/media-sound/guitarix/guitarix-0.42.1.ebuild b/media-sound/guitarix/guitarix-0.42.1.ebuild
index 3a9ca22629b1..19a6df94df79 100644
--- a/media-sound/guitarix/guitarix-0.42.1.ebuild
+++ b/media-sound/guitarix/guitarix-0.42.1.ebuild
@@ -65,6 +65,7 @@ DOCS=( changelog README )
PATCHES=(
"${FILESDIR}"/${PN}-0.41.0-nostrip.patch
+ "${FILESDIR}"/${P}-fix-build-with-glib-2.68.patch
)
src_configure() {