summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2020-11-16 09:36:20 +0100
committerMiroslav Šulc <fordfrog@gentoo.org>2020-11-16 09:36:34 +0100
commit859f4fb57cd0a59714e9e031ebbb3f9701c67878 (patch)
treeed290911e0bf78540043ce395bd3e580b386fe46 /media-sound/din
parentdev-python/pyglet: Bump to 1.5.10 (diff)
downloadgentoo-859f4fb57cd0a59714e9e031ebbb3f9701c67878.tar.gz
gentoo-859f4fb57cd0a59714e9e031ebbb3f9701c67878.tar.bz2
gentoo-859f4fb57cd0a59714e9e031ebbb3f9701c67878.zip
media-sound/din: bump to 49.1
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'media-sound/din')
-rw-r--r--media-sound/din/Manifest1
-rw-r--r--media-sound/din/din-49.1.ebuild57
-rw-r--r--media-sound/din/files/din-49.1-makefile.patch14
3 files changed, 72 insertions, 0 deletions
diff --git a/media-sound/din/Manifest b/media-sound/din/Manifest
index 4d6a905d5877..20326d097589 100644
--- a/media-sound/din/Manifest
+++ b/media-sound/din/Manifest
@@ -1 +1,2 @@
DIST din-48.tar.gz 3673917 BLAKE2B 90e29efcc159936e7dca5b1deba07d6ddf23fc6878053283c1723eaf73c9b06903d274e471c3043d57fb2cb923eb9516a06362590a6b555884dc1b7cb7b6e9c1 SHA512 3d54c3db23fe909a3664412f1bbba3898b83184d19c4b04f4432cd0bff0dede01d017cebe36980a3f8158ffbb663e09dd83a0de7206247b47fcc1a9f3b4cc940
+DIST din-49.1.tar.gz 3677087 BLAKE2B 7b696597327493d354c5efd31df243c70f23ec8d68514892c79212b9d3d398c7debb28ad95b6ccb04dc76ac0a9b01ee57d8245260dd4af99cd3f3b27bc2ecbcf SHA512 8f72fd1dce7197135e174bc8c4fb5325e7755e656d7817bbd82c964083ca48b0b5cc939472acf3464fd0404631767bbea1f20b7dea073b6829582e76d2879e04
diff --git a/media-sound/din/din-49.1.ebuild b/media-sound/din/din-49.1.ebuild
new file mode 100644
index 000000000000..08b3a14fa0f7
--- /dev/null
+++ b/media-sound/din/din-49.1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools eutils xdg
+
+DESCRIPTION="a software musical instrument and audio synthesizer"
+HOMEPAGE="https://dinisnoise.org/"
+SRC_URI="https://archive.org/download/dinisnoise_source_code/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+alsa jack"
+
+RDEPEND="
+ dev-lang/tcl:0=
+ media-libs/libsdl:=
+ virtual/glu
+ virtual/opengl
+ alsa? ( media-libs/alsa-lib )
+ jack? ( virtual/jack )
+"
+DEPEND="
+ ${RDEPEND}
+ dev-libs/boost
+"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+REQUIRED_USE="|| ( alsa jack )"
+
+PATCHES=(
+ "${FILESDIR}/${P}-makefile.patch"
+ "${FILESDIR}/${PN}-48-fix-random-constants.patch"
+)
+
+src_prepare() {
+ default
+
+ edos2unix pixmaps/${PN}.desktop
+
+ use jack && (sed -i "s/-lasound/-ljack/g" src/Makefile.am || die "Failed to fix jack linking")
+
+ eautoreconf
+}
+
+src_configure() {
+ # Jack takes over alsa.
+ local sound_engine
+
+ use jack && sound_engine="UNIX_JACK" || sound_engine="LINUX_ALSA"
+
+ econf CXXFLAGS="${CXXFLAGS} -D__${sound_engine}__"
+}
diff --git a/media-sound/din/files/din-49.1-makefile.patch b/media-sound/din/files/din-49.1-makefile.patch
new file mode 100644
index 000000000000..0a96d894c2c0
--- /dev/null
+++ b/media-sound/din/files/din-49.1-makefile.patch
@@ -0,0 +1,14 @@
+diff --git a/src/Makefile.am b/src/Makefile.am
+index c7cc5ce..2b07a9b 100644
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -1,7 +1,7 @@
+ #dinincludedir = $(pkgsrcdir)
+
+-AM_CXXFLAGS = -I /usr/include/tcl8.6 -Wall -D_THREAD_SAFE -DHAVE_OPENGL -D__LICENSED__ -D __SVG__ -D__GPL20__ -D __BOOST_TIME__ -DPREFIX=\"@prefix@\"
+-LIBS += -ltcl8.6 -lSDL -lGL -lpthread -lasound
++AM_CXXFLAGS = -Wall -D_THREAD_SAFE -DHAVE_OPENGL -D__LICENSED__ -D __SVG__ -D__GPL20__ -D __BOOST_TIME__ -DPREFIX=\"@prefix@\"
++LIBS += -ltcl -lSDL -lGL -lpthread -lasound
+
+ bin_PROGRAMS = din
+ din_SOURCES = alarm.cc arrow_button.cc audio.cc authors_note.cc ball.cc ball_ops.cc basic_editor.cc beat2value.cc binaural_drone.cc binaural_drones.cc bit_display.cc box_selector.cc button.cc capturer.cc checkbutton.cc chrono.cc circler.cc command.cc compressor.cc console.cc console_iterator.cc countries.cc cross_button.cc curve.cc curve_display.cc curve_editor.cc curve_library.cc curve_mixer.cc curve_picker.cc curve_samples.cc custom_periodic.cc delay.cc din.cc din_info.cc drone.cc fader.cc fft.cc field.cc filled_button.cc font.cc font_editor.cc fractaliser.cc globals.cc glyph.cc gravity.cc hit.cc help.cc item_list.cc keyboard_keyboard.cc label.cc levels.cc line.cc lissajous.cc listeners.cc main.cc menu.cc mesh.cc midi_in.cc minus_button.cc mocap.cc modulator.cc mondrian.cc morpher.cc morse_code.cc mouse_slider.cc multi_curve.cc note.cc noiser.cc number.cc oscilloscope.cc phrasor.cc play.cc plugin.cc plugin_browser.cc plus_button.cc point_modulator.cc range.cc recorder.cc rect.cc rose_milker.cc scale_info.cc scale_notes.cc scalelist.cc separator.cc settings.cc sine_mixer.cc slit.cc solver.cc spiraler.cc starrer.cc superformula.cc tap_bpm.cc tcl_interp.cc textboard.cc tokenizer.cc trail.cc triggered_note.cc ui.cc ui_sin_cos_radius.cc viewwin.cc warper.cc widget.cc kiss_fft.c RtAudio.cpp RtMidi.cpp