summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-02-21 12:08:36 +0100
committerLars Wendler <polynomial-c@gentoo.org>2018-02-21 12:08:51 +0100
commit2756b165ad00e4e78bfe5b02a3c0f5bd6f6be82c (patch)
treebcab8e4c1833a175b60c52f4e73de1eccb185bd7 /media-sound/audacity/audacity-2.2.2.ebuild
parentmedia-sound/audacity: Fixed compilation with USE="-midi" (diff)
downloadgentoo-2756b165ad00e4e78bfe5b02a3c0f5bd6f6be82c.tar.gz
gentoo-2756b165ad00e4e78bfe5b02a3c0f5bd6f6be82c.tar.bz2
gentoo-2756b165ad00e4e78bfe5b02a3c0f5bd6f6be82c.zip
media-sound/audacity: Fixed compilation with USE="-portmixer"
Closes: https://bugs.gentoo.org/624264 Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'media-sound/audacity/audacity-2.2.2.ebuild')
-rw-r--r--media-sound/audacity/audacity-2.2.2.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/media-sound/audacity/audacity-2.2.2.ebuild b/media-sound/audacity/audacity-2.2.2.ebuild
index cb2b8ea861f4..5c71e713a5d4 100644
--- a/media-sound/audacity/audacity-2.2.2.ebuild
+++ b/media-sound/audacity/audacity-2.2.2.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=5
-inherit eutils gnome2-utils wxwidgets xdg-utils
+inherit autotools eutils gnome2-utils wxwidgets xdg-utils
MY_P="${PN}-minsrc-${PV}"
DOC_PV="${PV}"
@@ -50,11 +50,16 @@ REQUIRED_USE="soundtouch? ( midi )"
S="${WORKDIR}/${MY_P}-rc1"
PATCHES=(
- "${FILESDIR}/${PN}-2.2.2-midi.patch"
+ "${FILESDIR}/${PN}-2.2.1-portmixer.patch" #624264
+ "${FILESDIR}/${PN}-2.2.2-automake.patch" # or else eautoreconf breaks
+ "${FILESDIR}/${PN}-2.2.2-midi.patch" #637110
)
src_prepare() {
epatch "${PATCHES[@]}"
+
+ # needed because of portmixer patch
+ eautoreconf
}
src_configure() {