summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2018-01-01 19:58:13 +0100
committerMiroslav Šulc <fordfrog@gentoo.org>2018-01-01 19:58:59 +0100
commit748599346a9bc94369d5051846081988c1081fc4 (patch)
treea75eff0fefb6a00502fd1876c563fc8c60596047 /media-sound/alsaplayer
parentdev-python/pytest-qt: fix metadata.xml (diff)
downloadgentoo-748599346a9bc94369d5051846081988c1081fc4.tar.gz
gentoo-748599346a9bc94369d5051846081988c1081fc4.tar.bz2
gentoo-748599346a9bc94369d5051846081988c1081fc4.zip
media-sound/alsaplayer: switched from media-sound/jack-audio-connection-kit to virtual/jack
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'media-sound/alsaplayer')
-rw-r--r--media-sound/alsaplayer/alsaplayer-0.99.81-r1.ebuild83
1 files changed, 83 insertions, 0 deletions
diff --git a/media-sound/alsaplayer/alsaplayer-0.99.81-r1.ebuild b/media-sound/alsaplayer/alsaplayer-0.99.81-r1.ebuild
new file mode 100644
index 000000000000..f1d448e8b1da
--- /dev/null
+++ b/media-sound/alsaplayer/alsaplayer-0.99.81-r1.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools desktop
+
+DESCRIPTION="A heavily multi-threaded pluggable audio player"
+HOMEPAGE="http://www.alsaplayer.org/"
+SRC_URI="http://www.alsaplayer.org/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~ppc ~sparc ~x86"
+IUSE="+alsa audiofile doc flac gtk id3tag jack mad mikmod nas nls ogg opengl oss vorbis xosd"
+
+RDEPEND="
+ media-libs/libsndfile:=
+ sys-libs/zlib:=
+ alsa? ( media-libs/alsa-lib )
+ audiofile? ( media-libs/audiofile )
+ flac? ( media-libs/flac )
+ gtk? ( >=x11-libs/gtk+-2.10:2 )
+ id3tag? ( media-libs/libid3tag )
+ jack? ( virtual/jack )
+ mad? ( media-libs/libmad )
+ mikmod? ( media-libs/libmikmod:0 )
+ nas? ( media-libs/nas )
+ ogg? ( media-libs/libogg )
+ opengl? ( virtual/opengl )
+ vorbis? ( media-libs/libvorbis )
+ xosd? ( x11-libs/xosd )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+ nls? ( sys-devel/gettext )
+ oss? ( virtual/os-headers )"
+REQUIRED_USE="|| ( alsa jack nas oss )"
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e 's:AM_CFLAGS = $(AM_CXXFLAGS)::' \
+ output/jack/Makefile.am || die
+
+ sed -i \
+ -e 's:-O2 -funroll-loops -finline-functions -ffast-math::' \
+ configure.ac || die
+
+ eautoreconf
+}
+
+src_configure() {
+ export ac_cv_prog_HAVE_DOXYGEN=$(usex doc true false)
+ export ac_cv_lib_xosd_xosd_create=$(usex xosd)
+
+ econf \
+ --disable-esd \
+ $(use_enable nls) \
+ $(use_enable opengl) \
+ $(use_enable mikmod) \
+ $(use_enable vorbis oggvorbis) \
+ $(use_enable audiofile) \
+ $(use_enable flac) \
+ $(use_enable mad) \
+ $(use_enable id3tag) \
+ $(use_enable gtk systray) \
+ $(use_enable jack) \
+ $(use_enable alsa) \
+ $(use_enable oss) \
+ $(use_enable gtk gtk2) \
+ $(use_enable nas)
+}
+
+src_install() {
+ default
+ dodoc docs/*.txt
+
+ newicon interface/gtk2/pixmaps/logo.xpm ${PN}.xpm
+
+ find "${D}" -name '*.la' -delete || die
+}