summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2019-11-13 10:49:45 +0100
committerMiroslav Šulc <fordfrog@gentoo.org>2019-11-13 10:52:39 +0100
commitdb1ea43e9bd591385324e58f1e33ed03e3ca3231 (patch)
tree3e7c0973cd2a9361079764b4f0128392a3e9e406 /media-sound/a2jmidid/a2jmidid-9.ebuild
parentkde-plasma/plasma-workspace-wallpapers: Previous fix requires a revbump (diff)
downloadgentoo-db1ea43e9bd591385324e58f1e33ed03e3ca3231.tar.gz
gentoo-db1ea43e9bd591385324e58f1e33ed03e3ca3231.tar.bz2
gentoo-db1ea43e9bd591385324e58f1e33ed03e3ca3231.zip
media-sound/a2jmidid-{9,9999}: bump + added live
1) changed to live project on github.com 2) ebuild rewritten to use mason 3) EAPI-7 4) added BDEPEND 5) updated DOCS Package-Manager: Portage-2.3.79, Repoman-2.3.18 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'media-sound/a2jmidid/a2jmidid-9.ebuild')
-rw-r--r--media-sound/a2jmidid/a2jmidid-9.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/media-sound/a2jmidid/a2jmidid-9.ebuild b/media-sound/a2jmidid/a2jmidid-9.ebuild
new file mode 100644
index 000000000000..8879e053f463
--- /dev/null
+++ b/media-sound/a2jmidid/a2jmidid-9.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="Daemon for exposing legacy ALSA sequencer applications in JACK MIDI system"
+HOMEPAGE="https://github.com/linuxaudio/a2jmidid"
+SRC_URI="https://github.com/linuxaudio/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="dbus"
+
+BDEPEND="
+ virtual/pkgconfig
+"
+CDEPEND="
+ ${PYTHON_DEPS}
+ media-libs/alsa-lib
+ virtual/jack
+ dbus? ( sys-apps/dbus )
+"
+RDEPEND="${CDEPEND}"
+DEPEND="${RDEPEND}"
+
+DOCS=( AUTHORS.rst CHANGELOG.rst README.rst internals.txt )
+
+src_configure() {
+ local emasonargs=(
+ -Ddisable-dbus=$(usex dbus false true)
+ )
+
+ meson_src_configure
+}