summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-06-18 23:03:18 +0200
committerDavid Seifert <soap@gentoo.org>2021-06-18 23:03:18 +0200
commitfa6f8444084ec2df85971b697978571fc1a73d21 (patch)
treef00550a3ea05b386a6fbd98b10f2d56e5688b886 /media-plugins/vdr-imonlcd
parentmedia-plugins/vdr-extrecmenu: respect PKG_CONFIG, tidy patches (diff)
downloadgentoo-fa6f8444084ec2df85971b697978571fc1a73d21.tar.gz
gentoo-fa6f8444084ec2df85971b697978571fc1a73d21.tar.bz2
gentoo-fa6f8444084ec2df85971b697978571fc1a73d21.zip
media-plugins/vdr-imonlcd: respect PKG_CONFIG
Signed-off-by: Sam James <sam@gentoo.org> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'media-plugins/vdr-imonlcd')
-rw-r--r--media-plugins/vdr-imonlcd/files/vdr-imonlcd-1.0.2-freetype_pkgconfig.patch4
-rw-r--r--media-plugins/vdr-imonlcd/vdr-imonlcd-1.0.2.ebuild8
2 files changed, 9 insertions, 3 deletions
diff --git a/media-plugins/vdr-imonlcd/files/vdr-imonlcd-1.0.2-freetype_pkgconfig.patch b/media-plugins/vdr-imonlcd/files/vdr-imonlcd-1.0.2-freetype_pkgconfig.patch
index 3c35846608f7..2e570b89f8ac 100644
--- a/media-plugins/vdr-imonlcd/files/vdr-imonlcd-1.0.2-freetype_pkgconfig.patch
+++ b/media-plugins/vdr-imonlcd/files/vdr-imonlcd-1.0.2-freetype_pkgconfig.patch
@@ -19,8 +19,8 @@ index fc165e9..36fc681 100644
-INCLUDES += $(shell freetype-config --cflags)
-LIBS += $(shell freetype-config --libs)
-+INCLUDES += $(shell pkg-config --cflags freetype2)
-+LIBS += $(shell pkg-config --libs freetype2)
++INCLUDES += $(shell ${PKG_CONFIG} --cflags freetype2)
++LIBS += $(shell ${PKG_CONFIG} --libs freetype2)
DEFINES += -DPLUGIN_NAME_I18N='"$(PLUGIN)"'
diff --git a/media-plugins/vdr-imonlcd/vdr-imonlcd-1.0.2.ebuild b/media-plugins/vdr-imonlcd/vdr-imonlcd-1.0.2.ebuild
index 2a66910fab92..75f9c6b555b3 100644
--- a/media-plugins/vdr-imonlcd/vdr-imonlcd-1.0.2.ebuild
+++ b/media-plugins/vdr-imonlcd/vdr-imonlcd-1.0.2.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit linux-info udev vdr-plugin-2
+inherit linux-info toolchain-funcs udev vdr-plugin-2
VERSION="2086" # every bump, new version
@@ -20,6 +20,7 @@ RDEPEND="
virtual/udev"
DEPEND="${RDEPEND}
media-video/vdr"
+BDEPEND="virtual/pkgconfig"
QA_FLAGS_IGNORED="
usr/lib/vdr/plugins/libvdr-.*
usr/lib64/vdr/plugins/libvdr-.*"
@@ -38,6 +39,11 @@ pkg_setup() {
vdr-plugin-2_pkg_setup
}
+src_configure() {
+ tc-export PKG_CONFIG
+ default
+}
+
src_install() {
rm -f README.git
vdr-plugin-2_src_install