summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorViolet Purcell <vimproved@inventati.org>2023-09-21 20:30:39 -0400
committerSam James <sam@gentoo.org>2023-09-22 16:42:48 +0100
commit5bb1147e3cd021653250f8e1855c849683cbea5f (patch)
treedbac9eab4a8ee2341c61016ed6b12967270bfd17 /media-plugins/calf/calf-9999.ebuild
parentmedia-plugins/calf: Backport clang fix (diff)
downloadgentoo-5bb1147e3cd021653250f8e1855c849683cbea5f.tar.gz
gentoo-5bb1147e3cd021653250f8e1855c849683cbea5f.tar.bz2
gentoo-5bb1147e3cd021653250f8e1855c849683cbea5f.zip
media-plugins/calf: Explicitly add -fno-fast-math when using compiler-rt
Signed-off-by: Violet Purcell <vimproved@inventati.org> Closes: https://github.com/gentoo/gentoo/pull/32980 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-plugins/calf/calf-9999.ebuild')
-rw-r--r--media-plugins/calf/calf-9999.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/media-plugins/calf/calf-9999.ebuild b/media-plugins/calf/calf-9999.ebuild
index f232db75e494..c83f53e73167 100644
--- a/media-plugins/calf/calf-9999.ebuild
+++ b/media-plugins/calf/calf-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit autotools xdg
+inherit autotools flag-o-matic toolchain-funcs xdg
DESCRIPTION="A set of open source instruments and effects for digital audio workstations"
HOMEPAGE="https://calf-studio-gear.org/"
@@ -56,6 +56,12 @@ src_prepare() {
}
src_configure() {
+ # Upstream append -ffast-math by default, however since libtool links C++
+ # shared libs with -nostdlib, this causes symbol resolution error for
+ # __powidn2 when using compiler-rt. Disable fast math on compiler-rt until
+ # a better fix is found.
+ [[ $(tc-get-c-rtlib) = "compiler-rt" ]] && append-cxxflags "-fno-fast-math"
+
local myeconfargs=(
--prefix="${EPREFIX}"/usr
--without-obsolete-check