summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-05-05 00:44:54 -0400
committerSam James <sam@gentoo.org>2024-05-05 12:47:11 +0100
commitbc2b3aa851eda2fa46b4253d04b1879831188752 (patch)
tree47b36eafa64da7c415a054ca02c87caa5b3dfc57 /media-libs
parentmedia-libs/libltc: sync live (diff)
downloadgentoo-bc2b3aa851eda2fa46b4253d04b1879831188752.tar.gz
gentoo-bc2b3aa851eda2fa46b4253d04b1879831188752.tar.bz2
gentoo-bc2b3aa851eda2fa46b4253d04b1879831188752.zip
media-libs/libltc: run elibtoolize in non-live ebuild
When building live, we always run eautoreconf. However, even in release mode we should still run elibtoolize to get important fixes -- such as the ones that pass through LTO sanity flags to the link phase. Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/libltc/libltc-1.3.2.ebuild9
-rw-r--r--media-libs/libltc/libltc-9999.ebuild7
2 files changed, 13 insertions, 3 deletions
diff --git a/media-libs/libltc/libltc-1.3.2.ebuild b/media-libs/libltc/libltc-1.3.2.ebuild
index 48b679efc14b..19a2a8ecf813 100644
--- a/media-libs/libltc/libltc-1.3.2.ebuild
+++ b/media-libs/libltc/libltc-1.3.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -9,6 +9,7 @@ if [[ ${PV} == *9999 ]]; then
inherit git-r3 autotools
EGIT_REPO_URI="https://github.com/x42/libltc"
else
+ inherit libtool
SRC_URI="https://github.com/x42/libltc/releases/download/v${PV}/${P}.tar.gz"
KEYWORDS="amd64"
fi
@@ -19,7 +20,11 @@ RESTRICT="mirror"
src_prepare() {
default
- [[ ${PV} == *9999 ]] && eautoreconf
+ if [[ ${PV} = *9999 ]]; then
+ eautoreconf
+ else
+ elibtoolize
+ fi
}
src_install() {
diff --git a/media-libs/libltc/libltc-9999.ebuild b/media-libs/libltc/libltc-9999.ebuild
index 1151950f7c7a..3049a511a985 100644
--- a/media-libs/libltc/libltc-9999.ebuild
+++ b/media-libs/libltc/libltc-9999.ebuild
@@ -9,6 +9,7 @@ if [[ ${PV} == *9999 ]]; then
inherit git-r3 autotools
EGIT_REPO_URI="https://github.com/x42/libltc"
else
+ inherit libtool
SRC_URI="https://github.com/x42/libltc/releases/download/v${PV}/${P}.tar.gz"
KEYWORDS="~amd64"
fi
@@ -19,7 +20,11 @@ RESTRICT="mirror"
src_prepare() {
default
- [[ ${PV} == *9999 ]] && eautoreconf
+ if [[ ${PV} = *9999 ]]; then
+ eautoreconf
+ else
+ elibtoolize
+ fi
}
src_install() {