summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-03-19 23:34:40 +0000
committerSam James <sam@gentoo.org>2022-03-19 23:34:40 +0000
commitb05f5b8e69f72d086b0a15f692096b215da4ff5a (patch)
tree1fbeacc862dce090edf793f8400e11660a205745 /media-libs
parentmedia-plugins/vdr-xineliboutput: [QA] fix tc-get* quoting (diff)
downloadgentoo-b05f5b8e69f72d086b0a15f692096b215da4ff5a.tar.gz
gentoo-b05f5b8e69f72d086b0a15f692096b215da4ff5a.tar.bz2
gentoo-b05f5b8e69f72d086b0a15f692096b215da4ff5a.zip
media-libs/libhdhomerun: [QA] fix tc-get* quoting
This can cause build problems for e.g. 32-bit (gcc -m32 ...) Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/libhdhomerun/libhdhomerun-20190621.ebuild6
-rw-r--r--media-libs/libhdhomerun/libhdhomerun-20200521.ebuild6
2 files changed, 6 insertions, 6 deletions
diff --git a/media-libs/libhdhomerun/libhdhomerun-20190621.ebuild b/media-libs/libhdhomerun/libhdhomerun-20190621.ebuild
index 0d2414e0360f..5bf973e3ce9b 100644
--- a/media-libs/libhdhomerun/libhdhomerun-20190621.ebuild
+++ b/media-libs/libhdhomerun/libhdhomerun-20190621.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -21,12 +21,12 @@ S="${WORKDIR}/${PN}"
src_prepare() {
default
- #Remove forced optimization from Makefile
+ # Remove forced optimization from Makefile
sed -i 's:-O2::' Makefile || die "Was the Makefile changed?"
}
src_compile() {
- emake CC=$(tc-getCC) STRIP=:
+ emake CC="$(tc-getCC)" STRIP=:
}
src_install() {
diff --git a/media-libs/libhdhomerun/libhdhomerun-20200521.ebuild b/media-libs/libhdhomerun/libhdhomerun-20200521.ebuild
index ba9622a7b375..a1673c6f3123 100644
--- a/media-libs/libhdhomerun/libhdhomerun-20200521.ebuild
+++ b/media-libs/libhdhomerun/libhdhomerun-20200521.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -21,12 +21,12 @@ S="${WORKDIR}/${PN}"
src_prepare() {
default
- #Remove forced optimization from Makefile
+ # Remove forced optimization from Makefile
sed -i 's:-O2::' Makefile || die "Was the Makefile changed?"
}
src_compile() {
- emake CC=$(tc-getCC) STRIP=:
+ emake CC="$(tc-getCC)" STRIP=:
}
src_install() {