summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2024-09-06 18:23:41 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2024-09-06 18:26:10 +0300
commit7c75a7beff10110cfaa8bceb3b6aa1b31408a4c3 (patch)
tree49306d7176a5b77a7bbec7d201efb6e2925f4fe6 /media-libs
parentdev-python/frozenlist: keyword 1.4.1 for ~mips (diff)
downloadgentoo-7c75a7beff10110cfaa8bceb3b6aa1b31408a4c3.tar.gz
gentoo-7c75a7beff10110cfaa8bceb3b6aa1b31408a4c3.tar.bz2
gentoo-7c75a7beff10110cfaa8bceb3b6aa1b31408a4c3.zip
media-libs/lv2: drop 1.18.10
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/lv2/lv2-1.18.10.ebuild85
1 files changed, 0 insertions, 85 deletions
diff --git a/media-libs/lv2/lv2-1.18.10.ebuild b/media-libs/lv2/lv2-1.18.10.ebuild
deleted file mode 100644
index 7896910a2127..000000000000
--- a/media-libs/lv2/lv2-1.18.10.ebuild
+++ /dev/null
@@ -1,85 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{9..11} )
-PYTHON_REQ_USE='threads(+)'
-
-inherit meson-multilib python-single-r1
-
-DESCRIPTION="A simple but extensible successor of LADSPA"
-HOMEPAGE="https://lv2plug.in/"
-SRC_URI="https://lv2plug.in/spec/${P}.tar.xz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv ~sparc x86"
-IUSE="doc plugins test"
-RESTRICT="!test? ( test )"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-BDEPEND="
- plugins? ( virtual/pkgconfig )
- doc? (
- app-text/doxygen
- dev-python/rdflib
- )
- test? (
- dev-libs/serd
- dev-libs/sord[tools]
- dev-python/rdflib
- )
-"
-CDEPEND="
- ${PYTHON_DEPS}
- plugins? (
- media-libs/libsamplerate
- media-libs/libsndfile
- x11-libs/gtk+:2[${MULTILIB_USEDEP}]
- )
-"
-DEPEND="
- ${CDEPEND}
- doc? ( dev-python/markdown )
-"
-RDEPEND="
- ${CDEPEND}
- $(python_gen_cond_dep '
- dev-python/lxml[${PYTHON_USEDEP}]
- dev-python/pygments[${PYTHON_USEDEP}]
- dev-python/rdflib[${PYTHON_USEDEP}]
- ')
-"
-
-PATCHES=(
- "${FILESDIR}/${PN}-1.18.6-add-missing-lv2.h.patch"
- "${FILESDIR}/${P}-tests-optional.patch"
-)
-
-src_prepare() {
- default
-
- # XXX: Drop this > 1.18.10, -Dstrict=false should prevent it now, bug #906047.
- sed -i -e "/codespell = /s:get_option('tests'):false:" test/meson.build || die
-
- # fix doc installation path
- sed -iE "s%lv2_docdir = .*%lv2_docdir = '"${EPREFIX}"/usr/share/doc/${PF}'%g" meson.build || die
-}
-
-multilib_src_configure() {
- local emesonargs=(
- -Dlv2dir="${EPREFIX}"/usr/$(get_libdir)/lv2
- -Dstrict=false
- $(meson_native_use_feature doc docs)
- $(meson_feature plugins)
- $(meson_feature test tests)
- )
-
- meson_src_configure
-}
-
-multilib_src_install_all() {
- local DOCS=( NEWS README.md )
- einstalldocs
-}