summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Flogeras <dflogeras2@gmail.com>2022-08-16 20:45:31 -0300
committerJoonas Niilola <juippis@gentoo.org>2022-08-31 11:31:19 +0300
commit604ba07b30e4a37e3ca3f006cda511caa9a05e63 (patch)
tree8bf3be7efdc24238676229c4428c8a0815c1686a /media-libs
parentmedia-gfx/converseen: add myself as a maintainer (diff)
downloadgentoo-604ba07b30e4a37e3ca3f006cda511caa9a05e63.tar.gz
gentoo-604ba07b30e4a37e3ca3f006cda511caa9a05e63.tar.bz2
gentoo-604ba07b30e4a37e3ca3f006cda511caa9a05e63.zip
media-libs/kcolorpicker: bump to 0.2.0
Bug: https://bugs.gentoo.org/865453 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: David Flogeras <dflogeras2@gmail.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/kcolorpicker/Manifest1
-rw-r--r--media-libs/kcolorpicker/kcolorpicker-0.2.0.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/media-libs/kcolorpicker/Manifest b/media-libs/kcolorpicker/Manifest
index 1c84a5bca80d..dbcfbeebf781 100644
--- a/media-libs/kcolorpicker/Manifest
+++ b/media-libs/kcolorpicker/Manifest
@@ -1 +1,2 @@
DIST kColorPicker-0.1.6.tar.gz 12028 BLAKE2B dda08211b56186a34afa9049a2770d98b25659fb0e9fed344f9305420ddc5f69517684236d2d1b1613cec0661f6af43fc463a0cc403bead27d0b6c535030d7d4 SHA512 9702b0dfd9d340aa2b043711b27f2ac1994ff6cdd06e912deb410bd3500a2b68fa046d91bbd1392f3c95905e4cf7660819d70864cc85e55cb4c8879e820e7cec
+DIST kColorPicker-0.2.0.tar.gz 12735 BLAKE2B 39b0c80ec5b498800dd251901b0bd57c839693f071185afacefa8d5a715ff18f2297c50486d98871471c40e0904a07ff40198b548d9368937b120a1eef07929f SHA512 44f9f317ebe5dd3131a9e44071f9f5b397b0d5cceece566f3ecf19932c8e36dafe1a434e623239421bead9413f0859bc3380174d7f14843770691e4d15a956eb
diff --git a/media-libs/kcolorpicker/kcolorpicker-0.2.0.ebuild b/media-libs/kcolorpicker/kcolorpicker-0.2.0.ebuild
new file mode 100644
index 000000000000..4e15369406c2
--- /dev/null
+++ b/media-libs/kcolorpicker/kcolorpicker-0.2.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+VIRTUALX_REQUIRED="test"
+inherit cmake virtualx
+
+MY_PN=kColorPicker
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Qt based color picker with popup menu"
+HOMEPAGE="https://github.com/ksnip/kColorPicker"
+SRC_URI="https://github.com/ksnip/${MY_PN}/archive/v${PV}.tar.gz -> ${MY_P}.tar.gz"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5[png]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-qt/qttest:5 )
+"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTS=$(usex test)
+ )
+ cmake_src_configure
+}
+
+src_test() {
+ virtx cmake_src_test
+}