summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernd Waibel <waebbl-gentoo@posteo.net>2021-05-19 23:41:38 +0200
committerSam James <sam@gentoo.org>2021-06-01 00:27:50 +0000
commit0e719b19ac0d518305ec3ca9cef56cb8741742b1 (patch)
tree1a702eebae8c27df0544af28aa58ed2abe9cacf6 /media-libs
parentmedia-libs/ilmbase: bump to 2.5.6 (diff)
downloadgentoo-0e719b19ac0d518305ec3ca9cef56cb8741742b1.tar.gz
gentoo-0e719b19ac0d518305ec3ca9cef56cb8741742b1.tar.bz2
gentoo-0e719b19ac0d518305ec3ca9cef56cb8741742b1.zip
media-libs/openexr: bump to 2.5.6
Bug: https://bugs.gentoo.org/791136 Bug: https://bugs.gentoo.org/776808 Bug: https://bugs.gentoo.org/770229 Bug: https://bugs.gentoo.org/656680 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Bernd Waibel <waebbl-gentoo@posteo.net> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/openexr/Manifest1
-rw-r--r--media-libs/openexr/openexr-2.5.6.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/media-libs/openexr/Manifest b/media-libs/openexr/Manifest
index 385bf371a3ce..70d32b885711 100644
--- a/media-libs/openexr/Manifest
+++ b/media-libs/openexr/Manifest
@@ -1,2 +1,3 @@
DIST openexr-2.5.5.tar.gz 27536865 BLAKE2B d0c0b2fd39b2cfafb60b6d0de3960063ff62341cf22be519f874c0c83f05cb604c5d503bb8b88514c71c5a54a79afa80a7fd00c2df15ec2193f6b3cffdc117c6 SHA512 e511af26a8fe2175a641fd25d2dcc6ef807e00bee2aff06a4784125f916ffd47fe376fe0621d385b604180a239bbfee063f8ceee3f7b731fde3c38558e9fdcdf
+DIST openexr-2.5.6.tar.gz 27540385 BLAKE2B eea64c6ae4500de31673f3127da6ac98272e85a2c93e2aed96494cc24c397edbce508f0721387be5bbabc4dde596dccf61212709173b7cebd4212dbfbd1e4b65 SHA512 8d4582a5f2adcd5eb1486cabe033f9ecaa0292000bf7fa484a94e1d9ec908678a5a903fc6a1beba22bcd9c7f06ac51236834f448ea8aaf4462a338de886f0412
DIST openexr-3.0.1.tar.gz 25059445 BLAKE2B 76bce1ff830b5e32362bfaf91d39945add171c5c1f453968b2fa8ba41e0996064d3a104eb7759cea87477e96e8a52d548743c7d83f5c6131dd38aecdd47bd6dd SHA512 e450c55d150e4c0a8a9147f78fe1c73ea9134976444f8c77c832d0671d4c3796f96fee74d23f26cdb9383e658a33d6d57c989e9207d1edfc8556ad688ff25a5b
diff --git a/media-libs/openexr/openexr-2.5.6.ebuild b/media-libs/openexr/openexr-2.5.6.ebuild
new file mode 100644
index 000000000000..4f642f515588
--- /dev/null
+++ b/media-libs/openexr/openexr-2.5.6.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+CMAKE_ECLASS=cmake
+inherit cmake-multilib flag-o-matic toolchain-funcs
+
+DESCRIPTION="ILM's OpenEXR high dynamic-range image file format libraries"
+HOMEPAGE="https://www.openexr.com/"
+SRC_URI="https://github.com/AcademySoftwareFoundation/openexr/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${P}/OpenEXR"
+
+LICENSE="BSD"
+SLOT="0/25" # based on SONAME
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-solaris"
+IUSE="cpu_flags_x86_avx doc examples static-libs utils test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ ~media-libs/ilmbase-${PV}:=[static-libs?,${MULTILIB_USEDEP}]
+ sys-libs/zlib[${MULTILIB_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+DOCS=( PATENTS README.md )
+
+src_prepare() {
+ # Fix path for testsuite
+ sed -i -e "s:/var/tmp/:${T}:" "${S}"/IlmImfTest/tmpDir.h || die "failed to set temp path for tests"
+
+ if use abi_x86_32 && use test; then
+ eapply "${FILESDIR}/${PN}-2.5.2-0001-IlmImfTest-main.cpp-disable-tests.patch"
+ fi
+
+ multilib_foreach_abi cmake_src_prepare
+}
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTING=$(usex test)
+ -DINSTALL_OPENEXR_DOCS=$(usex doc)
+ -DINSTALL_OPENEXR_EXAMPLES=$(usex examples)
+ -DOPENEXR_BUILD_BOTH_STATIC_SHARED=$(usex static-libs)
+ -DOPENEXR_BUILD_UTILS=$(usex utils)
+ -DOPENEXR_INSTALL_PKG_CONFIG=ON
+ -DOPENEXR_USE_CLANG_TIDY=OFF # don't look for clang-tidy
+ )
+
+ cmake_src_configure
+}
+
+multilib_src_install_all() {
+ if use doc; then
+ DOCS+=( doc/*.pdf )
+ fi
+ einstalldocs
+
+ use examples && docompress -x /usr/share/doc/${PF}/examples
+}