summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-06-17 06:21:17 +0100
committerSam James <sam@gentoo.org>2024-06-17 06:22:18 +0100
commit0507ce586e0a33e7cdd7d642f097d8aade7ae093 (patch)
tree15ef419d23f33b9fc4b41e8844018f2793f2e064 /media-libs
parentmedia-libs/mlt: Stabilize 7.24.0 x86, #934201 (diff)
downloadgentoo-0507ce586e0a33e7cdd7d642f097d8aade7ae093.tar.gz
gentoo-0507ce586e0a33e7cdd7d642f097d8aade7ae093.tar.bz2
gentoo-0507ce586e0a33e7cdd7d642f097d8aade7ae093.zip
media-libs/flac: only build programs for native multilib ABI
Also, add some configure options: * --disable-version-from-git (we never want this, even if using e.g. a git hook for WORKDIR) * --disable-valgrind-testing (off by default but let's be explicit) Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/flac/flac-1.4.3.ebuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/media-libs/flac/flac-1.4.3.ebuild b/media-libs/flac/flac-1.4.3.ebuild
index f1c2416376c5..c6ba4c45cf3b 100644
--- a/media-libs/flac/flac-1.4.3.ebuild
+++ b/media-libs/flac/flac-1.4.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -31,13 +31,18 @@ multilib_src_configure() {
local myeconfargs=(
--disable-doxygen-docs
--disable-examples
+ --disable-valgrind-testing
+ --disable-version-from-git
$([[ ${CHOST} == *-darwin* ]] && echo "--disable-asm-optimizations")
+
$(use_enable cpu_flags_x86_avx avx)
$(use_enable cxx cpplibs)
$(use_enable debug)
$(use_enable ogg)
$(use_enable static-libs static)
+ $(multilib_native_enable programs)
+
# cross-compile fix (bug #521446)
# no effect if ogg support is disabled
--with-ogg
@@ -47,6 +52,8 @@ multilib_src_configure() {
}
multilib_src_test() {
+ # configure has --enable-exhaustive-tests we could pass...
+ # there's also --disable-thorough-test.
if [[ ${UID} != 0 ]]; then
# Parallel tests work for CMake but don't for autotools as of 1.4.3
# https://github.com/xiph/flac/commit/aaffdcaa969c19aee9dc89be420eae470b55e405