summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Zander <negril.nx+gentoo@gmail.com>2024-01-21 19:01:51 +0100
committerJoonas Niilola <juippis@gentoo.org>2024-02-14 11:26:38 +0200
commit5b9cb4db94d5520e018a1a99d38d444c9c95d159 (patch)
treee847d480f2c5c9e545f3f5814ea138dd9c9ac119 /media-libs/opensubdiv/files
parentnet-dns/knot-resolver: add 5.7.1 (diff)
downloadgentoo-5b9cb4db94d5520e018a1a99d38d444c9c95d159.tar.gz
gentoo-5b9cb4db94d5520e018a1a99d38d444c9c95d159.tar.bz2
gentoo-5b9cb4db94d5520e018a1a99d38d444c9c95d159.zip
media-libs/opensubdiv: 3.6.0 update
Removed all automagic dependencies. Changed CUDA interaction as a test-case for better binpkg support. - We adhere to CUDAARCHS or NVCCFLAGS. - For `MERGE_TYPE=source` we fall back to native. - For `MERGE_TYPE=buildonly` we fall back to all-major. - Removed clunky OSD_CUDA_NVCC_FLAGS which defaulted to ancient ARCHS. Replace src_install logic that removed extra files in favour of never installing them via src_prepare. Closes: https://bugs.gentoo.org/922952 Closes: https://bugs.gentoo.org/922950 Closes: https://bugs.gentoo.org/904070 Signed-off-by: Paul Zander <negril.nx+gentoo@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/35029 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'media-libs/opensubdiv/files')
-rw-r--r--media-libs/opensubdiv/files/opensubdiv-3.6.0-cudaflags.patch20
-rw-r--r--media-libs/opensubdiv/files/opensubdiv-3.6.0-use-gnuinstalldirs.patch38
2 files changed, 58 insertions, 0 deletions
diff --git a/media-libs/opensubdiv/files/opensubdiv-3.6.0-cudaflags.patch b/media-libs/opensubdiv/files/opensubdiv-3.6.0-cudaflags.patch
new file mode 100644
index 000000000000..0202c47d13a4
--- /dev/null
+++ b/media-libs/opensubdiv/files/opensubdiv-3.6.0-cudaflags.patch
@@ -0,0 +1,20 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -595,7 +595,7 @@ if(CUDA_FOUND)
+ )
+ set(OSD_GPU TRUE)
+
+- if (UNIX)
++ if (FALSE)
+ list( APPEND CUDA_NVCC_FLAGS -Xcompiler -fPIC )
+ # Use OSD_CUDA_NVCC_FLAGS to specify --gpu-architecture or other CUDA
+ # compilation options. The overrides here are only for compatibility
+@@ -609,7 +609,7 @@ if(CUDA_FOUND)
+ endif()
+ endif()
+
+- if (DEFINED OSD_CUDA_NVCC_FLAGS)
++ if (FALSE)
+ list( APPEND CUDA_NVCC_FLAGS ${OSD_CUDA_NVCC_FLAGS})
+ endif()
+
diff --git a/media-libs/opensubdiv/files/opensubdiv-3.6.0-use-gnuinstalldirs.patch b/media-libs/opensubdiv/files/opensubdiv-3.6.0-use-gnuinstalldirs.patch
new file mode 100644
index 000000000000..5beb5bc49664
--- /dev/null
+++ b/media-libs/opensubdiv/files/opensubdiv-3.6.0-use-gnuinstalldirs.patch
@@ -0,0 +1,38 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -25,6 +25,7 @@
+ cmake_minimum_required(VERSION 3.12)
+
+ project(OpenSubdiv)
++include(GNUInstallDirs)
+
+ # Set C++ standard requirements, allowing overrides
+ if (NOT DEFINED CMAKE_CXX_STANDARD)
+@@ -81,15 +82,15 @@ if (NOT DEFINED CMAKE_INSTALL_PREFIX)
+ endif()
+
+ if (NOT DEFINED CMAKE_INCDIR_BASE)
+- set( CMAKE_INCDIR_BASE include/opensubdiv )
++ set( CMAKE_INCDIR_BASE ${CMAKE_INSTALL_INCLUDEDIR}/opensubdiv )
+ endif()
+
+ if (NOT DEFINED CMAKE_BINDIR_BASE)
+- set( CMAKE_BINDIR_BASE bin )
++ set( CMAKE_BINDIR_BASE ${CMAKE_INSTALL_BINDIR} )
+ endif()
+
+ if (NOT DEFINED CMAKE_LIBDIR_BASE)
+- set( CMAKE_LIBDIR_BASE lib )
++ set( CMAKE_LIBDIR_BASE ${CMAKE_INSTALL_LIBDIR} )
+ endif()
+
+ if (NOT DEFINED CMAKE_FRAMEWORKDIR_BASE)
+@@ -101,7 +102,7 @@ if (NOT DEFINED CMAKE_PLUGINDIR_BASE)
+ endif()
+
+ if (NOT DEFINED CMAKE_DOCDIR_BASE)
+- set( CMAKE_DOCDIR_BASE share/doc/opensubdiv )
++ set( CMAKE_DOCDIR_BASE ${CMAKE_INSTALL_DOCDIR} )
+ else()
+ if (IS_ABSOLUTE ${CMAKE_DOCDIR_BASE})
+ set( CMAKE_DOCDIR_BASE "${CMAKE_DOCDIR_BASE}" )