summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-09-26 00:06:35 +0100
committerSam James <sam@gentoo.org>2023-09-26 00:06:35 +0100
commit2e918fa5767c83c04b9443f9c77f6ebbf779825a (patch)
tree0e46f126a8ab095ce0bafa20302cb971dd5eda69 /media-libs/mesa
parentnet-vpn/tor: add 0.4.8.7 (diff)
downloadgentoo-2e918fa5767c83c04b9443f9c77f6ebbf779825a.tar.gz
gentoo-2e918fa5767c83c04b9443f9c77f6ebbf779825a.tar.bz2
gentoo-2e918fa5767c83c04b9443f9c77f6ebbf779825a.zip
media-libs/mesa: pass LLVM_MAX_SLOT to get_llvm_prefix for old + missed spot
Followup to 5d50956db21f37b3216f09df5149686eb43a76d8. Add it for the intel case, not just opencl, to fix all instances. Backport the change to older ebuilds too. Closes: https://bugs.gentoo.org/914632 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-libs/mesa')
-rw-r--r--media-libs/mesa/mesa-23.1.6.ebuild4
-rw-r--r--media-libs/mesa/mesa-23.1.7.ebuild4
-rw-r--r--media-libs/mesa/mesa-23.1.8.ebuild4
-rw-r--r--media-libs/mesa/mesa-23.2.0_rc3.ebuild4
-rw-r--r--media-libs/mesa/mesa-23.2.0_rc4.ebuild2
-rw-r--r--media-libs/mesa/mesa-9999.ebuild2
6 files changed, 10 insertions, 10 deletions
diff --git a/media-libs/mesa/mesa-23.1.6.ebuild b/media-libs/mesa/mesa-23.1.6.ebuild
index 19073addfdf5..5012c2966fd8 100644
--- a/media-libs/mesa/mesa-23.1.6.ebuild
+++ b/media-libs/mesa/mesa-23.1.6.ebuild
@@ -371,7 +371,7 @@ multilib_src_configure() {
fi
if use llvm && use opencl; then
- PKG_CONFIG_PATH="$(get_llvm_prefix)/$(get_libdir)/pkgconfig"
+ PKG_CONFIG_PATH="$(get_llvm_prefix "${LLVM_MAX_SLOT}")/$(get_libdir)/pkgconfig"
# See https://gitlab.freedesktop.org/mesa/mesa/-/blob/main/docs/rusticl.rst
emesonargs+=(
$(meson_native_true gallium-rusticl)
@@ -399,7 +399,7 @@ multilib_src_configure() {
emesonargs+=(-Dvulkan-layers=${vulkan_layers#,})
if use llvm && use vulkan && use video_cards_intel; then
- PKG_CONFIG_PATH="$(get_llvm_prefix)/$(get_libdir)/pkgconfig"
+ PKG_CONFIG_PATH="$(get_llvm_prefix "${LLVM_MAX_SLOT}")/$(get_libdir)/pkgconfig"
emesonargs+=(-Dintel-clc=enabled)
else
emesonargs+=(-Dintel-clc=disabled)
diff --git a/media-libs/mesa/mesa-23.1.7.ebuild b/media-libs/mesa/mesa-23.1.7.ebuild
index 6036a8c0264b..0eff5117e2be 100644
--- a/media-libs/mesa/mesa-23.1.7.ebuild
+++ b/media-libs/mesa/mesa-23.1.7.ebuild
@@ -371,7 +371,7 @@ multilib_src_configure() {
fi
if use llvm && use opencl; then
- PKG_CONFIG_PATH="$(get_llvm_prefix)/$(get_libdir)/pkgconfig"
+ PKG_CONFIG_PATH="$(get_llvm_prefix "${LLVM_MAX_SLOT}")/$(get_libdir)/pkgconfig"
# See https://gitlab.freedesktop.org/mesa/mesa/-/blob/main/docs/rusticl.rst
emesonargs+=(
$(meson_native_true gallium-rusticl)
@@ -399,7 +399,7 @@ multilib_src_configure() {
emesonargs+=(-Dvulkan-layers=${vulkan_layers#,})
if use llvm && use vulkan && use video_cards_intel; then
- PKG_CONFIG_PATH="$(get_llvm_prefix)/$(get_libdir)/pkgconfig"
+ PKG_CONFIG_PATH="$(get_llvm_prefix "${LLVM_MAX_SLOT}")/$(get_libdir)/pkgconfig"
emesonargs+=(-Dintel-clc=enabled)
else
emesonargs+=(-Dintel-clc=disabled)
diff --git a/media-libs/mesa/mesa-23.1.8.ebuild b/media-libs/mesa/mesa-23.1.8.ebuild
index 6036a8c0264b..0eff5117e2be 100644
--- a/media-libs/mesa/mesa-23.1.8.ebuild
+++ b/media-libs/mesa/mesa-23.1.8.ebuild
@@ -371,7 +371,7 @@ multilib_src_configure() {
fi
if use llvm && use opencl; then
- PKG_CONFIG_PATH="$(get_llvm_prefix)/$(get_libdir)/pkgconfig"
+ PKG_CONFIG_PATH="$(get_llvm_prefix "${LLVM_MAX_SLOT}")/$(get_libdir)/pkgconfig"
# See https://gitlab.freedesktop.org/mesa/mesa/-/blob/main/docs/rusticl.rst
emesonargs+=(
$(meson_native_true gallium-rusticl)
@@ -399,7 +399,7 @@ multilib_src_configure() {
emesonargs+=(-Dvulkan-layers=${vulkan_layers#,})
if use llvm && use vulkan && use video_cards_intel; then
- PKG_CONFIG_PATH="$(get_llvm_prefix)/$(get_libdir)/pkgconfig"
+ PKG_CONFIG_PATH="$(get_llvm_prefix "${LLVM_MAX_SLOT}")/$(get_libdir)/pkgconfig"
emesonargs+=(-Dintel-clc=enabled)
else
emesonargs+=(-Dintel-clc=disabled)
diff --git a/media-libs/mesa/mesa-23.2.0_rc3.ebuild b/media-libs/mesa/mesa-23.2.0_rc3.ebuild
index b91c9e4f47da..2cbfe410d4dd 100644
--- a/media-libs/mesa/mesa-23.2.0_rc3.ebuild
+++ b/media-libs/mesa/mesa-23.2.0_rc3.ebuild
@@ -372,7 +372,7 @@ multilib_src_configure() {
fi
if use llvm && use opencl; then
- PKG_CONFIG_PATH="$(get_llvm_prefix)/$(get_libdir)/pkgconfig"
+ PKG_CONFIG_PATH="$(get_llvm_prefix "${LLVM_MAX_SLOT}")/$(get_libdir)/pkgconfig"
# See https://gitlab.freedesktop.org/mesa/mesa/-/blob/main/docs/rusticl.rst
emesonargs+=(
$(meson_native_true gallium-rusticl)
@@ -400,7 +400,7 @@ multilib_src_configure() {
emesonargs+=(-Dvulkan-layers=${vulkan_layers#,})
if use llvm && use vulkan && use video_cards_intel; then
- PKG_CONFIG_PATH="$(get_llvm_prefix)/$(get_libdir)/pkgconfig"
+ PKG_CONFIG_PATH="$(get_llvm_prefix "${LLVM_MAX_SLOT}")/$(get_libdir)/pkgconfig"
emesonargs+=(-Dintel-clc=enabled)
else
emesonargs+=(-Dintel-clc=disabled)
diff --git a/media-libs/mesa/mesa-23.2.0_rc4.ebuild b/media-libs/mesa/mesa-23.2.0_rc4.ebuild
index aec9de0ef437..02661bf2530d 100644
--- a/media-libs/mesa/mesa-23.2.0_rc4.ebuild
+++ b/media-libs/mesa/mesa-23.2.0_rc4.ebuild
@@ -395,7 +395,7 @@ multilib_src_configure() {
emesonargs+=(-Dvulkan-layers=${vulkan_layers#,})
if use llvm && use vulkan && use video_cards_intel; then
- PKG_CONFIG_PATH="$(get_llvm_prefix)/$(get_libdir)/pkgconfig"
+ PKG_CONFIG_PATH="$(get_llvm_prefix "${LLVM_MAX_SLOT}")/$(get_libdir)/pkgconfig"
emesonargs+=(-Dintel-clc=enabled)
else
emesonargs+=(-Dintel-clc=disabled)
diff --git a/media-libs/mesa/mesa-9999.ebuild b/media-libs/mesa/mesa-9999.ebuild
index 8a7607d2aa2e..62cd12fe1eee 100644
--- a/media-libs/mesa/mesa-9999.ebuild
+++ b/media-libs/mesa/mesa-9999.ebuild
@@ -396,7 +396,7 @@ multilib_src_configure() {
emesonargs+=(-Dvulkan-layers=${vulkan_layers#,})
if use llvm && use vulkan && use video_cards_intel; then
- PKG_CONFIG_PATH="$(get_llvm_prefix)/$(get_libdir)/pkgconfig"
+ PKG_CONFIG_PATH="$(get_llvm_prefix "${LLVM_MAX_SLOT}")/$(get_libdir)/pkgconfig"
emesonargs+=(-Dintel-clc=enabled)
else
emesonargs+=(-Dintel-clc=disabled)