summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorViorel Munteanu <ceamac@gentoo.org>2024-04-08 08:14:20 +0300
committerViorel Munteanu <ceamac@gentoo.org>2024-04-08 08:32:50 +0300
commit05afd8887bc2a50d110e01aa705debb73d7430ad (patch)
tree1d10951e71d2c2e8b4c61569a5c420ce862f1e3d /media-libs/libpgf
parentsci-libs/hdf: update EAPI 7 -> 8 (diff)
downloadgentoo-05afd8887bc2a50d110e01aa705debb73d7430ad.tar.gz
gentoo-05afd8887bc2a50d110e01aa705debb73d7430ad.tar.bz2
gentoo-05afd8887bc2a50d110e01aa705debb73d7430ad.zip
media-libs/libpgf: fix build on musl
The patch was incomplete, redo it. Closes: https://bugs.gentoo.org/927796 Signed-off-by: Viorel Munteanu <ceamac@gentoo.org>
Diffstat (limited to 'media-libs/libpgf')
-rw-r--r--media-libs/libpgf/files/libpgf-7.21.7-remove-off64_t.patch24
1 files changed, 8 insertions, 16 deletions
diff --git a/media-libs/libpgf/files/libpgf-7.21.7-remove-off64_t.patch b/media-libs/libpgf/files/libpgf-7.21.7-remove-off64_t.patch
index 9844bd589b94..c0ebd6fe431c 100644
--- a/media-libs/libpgf/files/libpgf-7.21.7-remove-off64_t.patch
+++ b/media-libs/libpgf/files/libpgf-7.21.7-remove-off64_t.patch
@@ -1,35 +1,27 @@
https://bugs.gentoo.org/907091
+https://bugs.gentoo.org/927796
-Remove off64_t, add AC_SYS_LARGEFILE to configure.ac instead
+Remove off64_t, lseek64, add AC_SYS_LARGEFILE to configure.ac instead
--- a/include/PGFplatform.h
+++ b/include/PGFplatform.h
-@@ -341,10 +341,6 @@
- #define __POSIX__
- #endif
-
--#ifndef off64_t
--#define off64_t off_t
--#endif
--
- #ifndef lseek64
- #define lseek64 lseek
- #endif
-@@ -536,7 +532,7 @@
+@@ -536,8 +536,8 @@
return NoError;
}
#else
- off64_t ret;
+- if ((ret = lseek64(hFile, 0, SEEK_CUR)) == -1) {
+ off_t ret;
- if ((ret = lseek64(hFile, 0, SEEK_CUR)) == -1) {
++ if ((ret = lseek(hFile, 0, SEEK_CUR)) == -1) {
return errno;
} else {
-@@ -554,7 +550,7 @@
+ *pos = (UINT64)ret;
+@@ -554,7 +554,7 @@
return NoError;
}
#else
- if ((lseek64(hFile, (off64_t)posOff, posMode)) == -1) {
-+ if ((lseek64(hFile, (off_t)posOff, posMode)) == -1) {
++ if ((lseek(hFile, (off_t)posOff, posMode)) == -1) {
return errno;
} else {
return NoError;