summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Flogeras <dflogeras2@gmail.com>2024-03-08 11:49:19 -0400
committerAndreas Sturmlechner <asturm@gentoo.org>2024-03-10 17:50:45 +0100
commitc8de61ac2924008a9f92c9696aabd97a7e3a1a77 (patch)
treea6c782ae56b8ebee49113e9b3ab0f8bae38a92c8 /media-libs/kcolorpicker
parentsci-geosciences/geopy: add 2.4.1 (diff)
downloadgentoo-c8de61ac2924008a9f92c9696aabd97a7e3a1a77.tar.gz
gentoo-c8de61ac2924008a9f92c9696aabd97a7e3a1a77.tar.bz2
gentoo-c8de61ac2924008a9f92c9696aabd97a7e3a1a77.zip
media-libs/kcolorpicker: add 0.3.1
Bug: https://bugs.gentoo.org/921699 Signed-off-by: David Flogeras <dflogeras2@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/35670 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-libs/kcolorpicker')
-rw-r--r--media-libs/kcolorpicker/Manifest1
-rw-r--r--media-libs/kcolorpicker/kcolorpicker-0.3.1.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/media-libs/kcolorpicker/Manifest b/media-libs/kcolorpicker/Manifest
index f57a68494be2..1c0d90f3ca41 100644
--- a/media-libs/kcolorpicker/Manifest
+++ b/media-libs/kcolorpicker/Manifest
@@ -1,2 +1,3 @@
DIST kColorPicker-0.2.0.tar.gz 12735 BLAKE2B 39b0c80ec5b498800dd251901b0bd57c839693f071185afacefa8d5a715ff18f2297c50486d98871471c40e0904a07ff40198b548d9368937b120a1eef07929f SHA512 44f9f317ebe5dd3131a9e44071f9f5b397b0d5cceece566f3ecf19932c8e36dafe1a434e623239421bead9413f0859bc3380174d7f14843770691e4d15a956eb
DIST kColorPicker-0.3.0.tar.gz 12998 BLAKE2B 18c8f36b3efe1fa3c4ae9fb0e9d7497393561d66287e7ce6b5139e0182ddc69866685a85f4794afb7c861fcb824bfebb4f3c4badf148b4c8aa8b88b7b3483db2 SHA512 9f370ad8de0f23116f513e14ca22cb368cb5eaea53484388ca5ca0b7abc81d5071379cb84f8128f806c9ffa051ad29a95e42d4c1d30ba93034c0ae9fd785bb8c
+DIST kColorPicker-0.3.1.tar.gz 12861 BLAKE2B 927ad41de0d9576d6fc004595a775715bcffeba7149a8111a7311fd44e8e58b01abbfda898174acefb9e0bad969420bf05eda45694cbc0cd8a3d3cf942709179 SHA512 bb91d8dfa555e60206665453cde8f4f7536154fe7660aeab276c0a509bdb19caf04276eb0935537b390657881db020ecb943de3e5b8d286f3cd7d89bf7010674
diff --git a/media-libs/kcolorpicker/kcolorpicker-0.3.1.ebuild b/media-libs/kcolorpicker/kcolorpicker-0.3.1.ebuild
new file mode 100644
index 000000000000..ba108063e02c
--- /dev/null
+++ b/media-libs/kcolorpicker/kcolorpicker-0.3.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 2020-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+MY_PN=kColorPicker
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Qt based color picker with popup menu"
+HOMEPAGE="https://github.com/ksnip/kColorPicker"
+SRC_URI="https://github.com/ksnip/${MY_PN}/archive/v${PV}.tar.gz -> ${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE="test"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-qt/qtbase:6[gui,widgets]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-qt/qtbase:6 )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTS=$(usex test)
+ -DBUILD_WITH_QT6=ON
+ )
+ cmake_src_configure
+}
+
+src_test() {
+ local -x QT_QPA_PLATFORM=offscreen
+ cmake_src_test
+}