summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarlson2k (Evgeny Grin) <k2k@narod.ru>2021-04-02 19:03:55 +0300
committerSam James <sam@gentoo.org>2021-04-12 23:08:10 +0000
commit42c14ae2fbdfd2816d075f012e2c23a4a5b59e4c (patch)
treeea5727d647e7e74a7690b21b7bcbc107385dd7f2 /media-libs/gmmlib/gmmlib-21.1.1.ebuild
parentx11-wm/xoat: add missing pkgconfig (B)DEPEND (diff)
downloadgentoo-42c14ae2fbdfd2816d075f012e2c23a4a5b59e4c.tar.gz
gentoo-42c14ae2fbdfd2816d075f012e2c23a4a5b59e4c.tar.bz2
gentoo-42c14ae2fbdfd2816d075f012e2c23a4a5b59e4c.zip
media-libs/gmmlib: new version 21.1.1
Signed-off-by: Karlson2k (Evgeny Grin) <k2k@narod.ru> Closes: https://github.com/gentoo/gentoo/pull/20235 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-libs/gmmlib/gmmlib-21.1.1.ebuild')
-rw-r--r--media-libs/gmmlib/gmmlib-21.1.1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/media-libs/gmmlib/gmmlib-21.1.1.ebuild b/media-libs/gmmlib/gmmlib-21.1.1.ebuild
new file mode 100644
index 000000000000..4e796e2186d3
--- /dev/null
+++ b/media-libs/gmmlib/gmmlib-21.1.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+CMAKE_ECLASS=cmake
+
+inherit cmake-multilib
+
+if [[ ${PV} == *9999 ]] ; then
+ : ${EGIT_REPO_URI:="https://github.com/intel/gmmlib"}
+ if [[ ${PV%9999} != "" ]] ; then
+ : ${EGIT_BRANCH:="release/${PV%.9999}"}
+ fi
+ inherit git-r3
+fi
+
+DESCRIPTION="Intel Graphics Memory Management Library"
+HOMEPAGE="https://github.com/intel/gmmlib"
+if [[ ${PV} == *9999 ]] ; then
+ SRC_URI=""
+else
+ SRC_URI="https://github.com/intel/gmmlib/archive/intel-${P}.tar.gz"
+ S="${WORKDIR}/${PN}-intel-${P}"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="test +custom-cflags"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-20.2.2_conditional_testing.patch
+ "${FILESDIR}"/${PN}-20.4.1_custom_cflags.patch
+)
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TYPE=Release
+ -DBUILD_TESTING=$(usex test)
+ -DOVERRIDE_COMPILER_FLAGS=$(usex !custom-cflags)
+ )
+ cmake_src_configure
+}