summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-05-30 04:50:58 +0100
committerSam James <sam@gentoo.org>2024-05-30 04:53:53 +0100
commit033629cddfc22d7bcead70daa7b6eaa76f0bc623 (patch)
tree8a86b94bf575144d7b4547743a0c50af2da8a7fa /media-libs/giflib/giflib-5.2.2.ebuild
parentnet-p2p/qbittorrent: add 4.6.5 (diff)
downloadgentoo-033629cddfc22d7bcead70daa7b6eaa76f0bc623.tar.gz
gentoo-033629cddfc22d7bcead70daa7b6eaa76f0bc623.tar.bz2
gentoo-033629cddfc22d7bcead70daa7b6eaa76f0bc623.zip
media-libs/giflib: add 5.2.2
The release notes mention CVE-2023-48161 and CVE-2022-28506 by CVE but there's a bunch of other security fixes in the list of fixes. The documentation in this release also adds: """ +<refsect1><title>Bugs</title> + +<para>Feeding this utility a GIF with an invalid colormap, or other +kinds of malformations, index will produce invalid output and may +core-dump the tool. Don't do that.</para> + +</refsect1> """ Anyway, on the ebuild side: * Replace Makefile patch for doc building conditionally with a sed * Make tests more verbose (needed it when debugging bug #848807) * Cleanup reallocarray hack (bug #677956) * Add LFS support (bug #915316) Bug: https://bugs.gentoo.org/677956 Bug: https://bugs.gentoo.org/785664 Bug: https://bugs.gentoo.org/851945 Bug: https://bugs.gentoo.org/918539 Closes: https://bugs.gentoo.org/848807 Closes: https://bugs.gentoo.org/915316 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-libs/giflib/giflib-5.2.2.ebuild')
-rw-r--r--media-libs/giflib/giflib-5.2.2.ebuild76
1 files changed, 76 insertions, 0 deletions
diff --git a/media-libs/giflib/giflib-5.2.2.ebuild b/media-libs/giflib/giflib-5.2.2.ebuild
new file mode 100644
index 000000000000..fe22c921f716
--- /dev/null
+++ b/media-libs/giflib/giflib-5.2.2.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic multilib-minimal toolchain-funcs
+
+DESCRIPTION="Library to handle, display and manipulate GIF images"
+HOMEPAGE="https://sourceforge.net/projects/giflib/"
+SRC_URI="https://downloads.sourceforge.net/giflib/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/7"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-solaris"
+IUSE="doc static-libs"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-5.2.1-fix-missing-quantize-API-symbols.patch
+ "${FILESDIR}"/${PN}-5.2.2-fortify.patch
+ "${FILESDIR}"/${PN}-5.2.2-verbose-tests.patch
+)
+
+src_prepare() {
+ default
+
+ # We don't want docs to be built unconditionally
+ sed -i -e '/$(MAKE) -C doc/d' Makefile || die
+
+ multilib_copy_sources
+}
+
+multilib_src_compile() {
+ append-lfs-flags
+
+ emake \
+ AR="$(tc-getAR)" \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS} -std=gnu99 -fPIC" \
+ LDFLAGS="${LDFLAGS}" \
+ OFLAGS="" \
+ all
+
+ if use doc && multilib_is_native_abi; then
+ emake -C doc
+ fi
+}
+
+multilib_src_test() {
+ emake -j1 check
+}
+
+multilib_src_install() {
+ emake \
+ DESTDIR="${D}" \
+ PREFIX="${EPREFIX}/usr" \
+ LIBDIR="${EPREFIX}/usr/$(get_libdir)" \
+ install
+
+ if ! use static-libs ; then
+ find "${ED}" -name "*.a" -delete || die
+ fi
+
+ if use doc && multilib_is_native_abi; then
+ docinto html
+ dodoc doc/*.html
+ fi
+}
+
+multilib_src_install_all() {
+ local DOCS=( ChangeLog NEWS README TODO )
+ einstalldocs
+ if use doc ; then
+ docinto html
+ dodoc -r doc/{gifstandard,whatsinagif}
+ fi
+}