summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2021-05-23 10:09:34 +0200
committerUlrich Müller <ulm@gentoo.org>2021-05-23 19:11:29 +0200
commitbed1f69d4c79783c4f3ce619568516624d9751dc (patch)
treefb6700f2dc3691716d7cca29f32c5843dee5f602 /media-gfx/word_cloud/word_cloud-1.8.1.ebuild
parentapp-arch/upx: remove old version (diff)
downloadgentoo-bed1f69d4c79783c4f3ce619568516624d9751dc.tar.gz
gentoo-bed1f69d4c79783c4f3ce619568516624d9751dc.tar.bz2
gentoo-bed1f69d4c79783c4f3ce619568516624d9751dc.zip
media-gfx/word_cloud: Version bump to 1.8.1
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'media-gfx/word_cloud/word_cloud-1.8.1.ebuild')
-rw-r--r--media-gfx/word_cloud/word_cloud-1.8.1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/media-gfx/word_cloud/word_cloud-1.8.1.ebuild b/media-gfx/word_cloud/word_cloud-1.8.1.ebuild
new file mode 100644
index 000000000000..566b07c3986f
--- /dev/null
+++ b/media-gfx/word_cloud/word_cloud-1.8.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+DISTUTILS_USE_SETUPTOOLS="rdepend"
+
+inherit distutils-r1
+
+DESCRIPTION="A little word cloud generator in Python"
+HOMEPAGE="https://amueller.github.io/word_cloud/"
+SRC_URI="https://github.com/amueller/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ media-fonts/droid"
+
+PATCHES=( "${FILESDIR}"/${PN}-1.6.0-bundled-font.patch )