summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuilherme Amadio <amadio@gentoo.org>2015-08-31 08:36:17 +0200
committerGuilherme Amadio <amadio@gentoo.org>2015-08-31 08:36:17 +0200
commitf1cb2b98f62fa9cbf1ef5a0f149dd47fee6964be (patch)
tree3572e985b933a3d8c2d3e727331e3b2ebcb542f8 /media-fonts/hack/hack-2.010.ebuild
parentmail-mta/postfix: version bump to postfix-3.1_pre20150829 (diff)
downloadgentoo-f1cb2b98f62fa9cbf1ef5a0f149dd47fee6964be.tar.gz
gentoo-f1cb2b98f62fa9cbf1ef5a0f149dd47fee6964be.tar.bz2
gentoo-f1cb2b98f62fa9cbf1ef5a0f149dd47fee6964be.zip
media-fonts/hack: new ebuild, bug 559192
Bug: 559192 Reported-by: José Romildo Malaquias <jrmalaq@gmail.com> Package-Manager: portage-2.2.20.1
Diffstat (limited to 'media-fonts/hack/hack-2.010.ebuild')
-rw-r--r--media-fonts/hack/hack-2.010.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/media-fonts/hack/hack-2.010.ebuild b/media-fonts/hack/hack-2.010.ebuild
new file mode 100644
index 000000000000..ed11e3a48e2f
--- /dev/null
+++ b/media-fonts/hack/hack-2.010.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit font versionator
+
+MyPV=
+
+DESCRIPTION="A typeface designed for source code"
+HOMEPAGE="https://github.com/chrissimpkins/Hack"
+SRC_URI="https://github.com/chrissimpkins/Hack/releases/download/v${PV}/Hack-v$(replace_version_separator 1 '_' )-otf.zip"
+
+LICENSE="OFL-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="binchecks strip"
+
+DEPEND="app-arch/unzip"
+RDEPEND=""
+
+FONT_SUFFIX="otf"
+
+src_unpack() {
+ mkdir "${S}" && cd "${S}"
+ unpack ${A}
+}