summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2023-01-28 13:48:55 +0100
committerPacho Ramos <pacho@gentoo.org>2023-01-28 14:28:51 +0100
commitd83d61ca1beb6951f857aa67151130aa4f999245 (patch)
treee7506d0c863d711e5608550e7fb96de7526fb3b6 /mate-extra/mate-indicator-applet
parentmate-extra/mate-indicator-applet: Choose indicator impl (diff)
downloadgentoo-d83d61ca1beb6951f857aa67151130aa4f999245.tar.gz
gentoo-d83d61ca1beb6951f857aa67151130aa4f999245.tar.bz2
gentoo-d83d61ca1beb6951f857aa67151130aa4f999245.zip
mate-extra/mate-indicator-applet: Use Ayatana indicators
Closes: https://bugs.gentoo.org/887705 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'mate-extra/mate-indicator-applet')
-rw-r--r--mate-extra/mate-indicator-applet/mate-indicator-applet-1.26.0-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/mate-extra/mate-indicator-applet/mate-indicator-applet-1.26.0-r1.ebuild b/mate-extra/mate-indicator-applet/mate-indicator-applet-1.26.0-r1.ebuild
new file mode 100644
index 000000000000..95ffd6971d79
--- /dev/null
+++ b/mate-extra/mate-indicator-applet/mate-indicator-applet-1.26.0-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit mate
+
+if [[ ${PV} != 9999 ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~riscv ~x86"
+fi
+
+DESCRIPTION="MATE indicator applet"
+LICENSE="GPL-3 GPL-3+ LGPL-2+ LGPL-3+"
+SLOT="0"
+
+IUSE=""
+
+COMMON_DEPEND="
+ dev-libs/libayatana-indicator:3
+ >=mate-base/mate-panel-1.17.0
+ >=x11-libs/gtk+-3.22:3
+"
+
+RDEPEND="${COMMON_DEPEND}
+ virtual/libintl
+"
+
+BDEPEND="${COMMON_DEPEND}
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_configure() {
+ mate_src_configure \
+ --with-ayatana-indicators
+}