summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOz Tiram <oz.tiram@gmail.com>2024-02-05 10:36:22 +0100
committerJoonas Niilola <juippis@gentoo.org>2024-02-07 16:53:21 +0200
commit0b59622790ebcb6492abd6e75e196b72aea3a261 (patch)
tree3cc46f53535f48a13e09b6f45b61ee99937096f6 /mate-base
parentmate-extra/caja-extensions: add 1.27.1 (diff)
downloadgentoo-0b59622790ebcb6492abd6e75e196b72aea3a261.tar.gz
gentoo-0b59622790ebcb6492abd6e75e196b72aea3a261.tar.bz2
gentoo-0b59622790ebcb6492abd6e75e196b72aea3a261.zip
mate-base/mate-panel: add 1.27.3
Signed-off-by: Oz Tiram <oz.tiram@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/35171 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'mate-base')
-rw-r--r--mate-base/mate-panel/Manifest1
-rw-r--r--mate-base/mate-panel/mate-panel-1.27.3.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/mate-base/mate-panel/Manifest b/mate-base/mate-panel/Manifest
index 526dcb634436..3acaa1420f79 100644
--- a/mate-base/mate-panel/Manifest
+++ b/mate-base/mate-panel/Manifest
@@ -1,2 +1,3 @@
DIST mate-panel-1.26.4.tar.xz 3262004 BLAKE2B 6561bdfe79f8b9f92db7fac1b3857bd0fb49b5220910f0aebc6eff443233c8cf2bdee8d21ffbdf88869ef1a99b3ffb96e0e22027099ef59d595ff596d79efdc3 SHA512 90db23f46dab88cb242aafb32737519d16e035843c2ca81da131ff3134a61b08772f19aa9900dbfbd00dcf4579cee3970765aa3fb461664abd1dd3babb8f6ea2
DIST mate-panel-1.27.2.tar.xz 3245284 BLAKE2B 9ec3110b0d16a7047c5fc79df54eba300ca55fcaad57df8cfec8896884bf080766a4fde7e04303fa32f77cf8ad3748872c81f7ade8e66fdb4cd600087a00351c SHA512 93431af5ffd1241c5fb56dd0a60eeba2de89e745502575cfd8f281700345689edc50ec653a6d9b1472a6d0e9d7d09a7e1439627fcacfdc627f187551cef21b6f
+DIST mate-panel-1.27.3.tar.xz 3282840 BLAKE2B 7424994f7f054184ee6ddcecf11c18f346ee23a6bf8669d280ff59012bebe972f4e82dd5f09aa0c21c3bf27ad8e5bff4a2cd0e710ae126ce01bf61597ff4c347 SHA512 47793a1cd631fcbaacaf94f599c250f4dc0f7733351743d4bc6b6ad279f92dfa6bed73f325d18516b764383a56ba3858d780cf8703eb9cd0449ce35b833cdba2
diff --git a/mate-base/mate-panel/mate-panel-1.27.3.ebuild b/mate-base/mate-panel/mate-panel-1.27.3.ebuild
new file mode 100644
index 000000000000..52a917988a26
--- /dev/null
+++ b/mate-base/mate-panel/mate-panel-1.27.3.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MATE_LA_PUNT="yes"
+
+inherit mate
+
+MINOR=$(($(ver_cut 2) % 2))
+if [[ ${MINOR} -eq 0 ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~riscv ~x86"
+fi
+
+DESCRIPTION="The MATE panel"
+LICENSE="FDL-1.1+ GPL-2+ LGPL-2+"
+SLOT="0"
+
+IUSE="+X +introspection wayland"
+
+REQUIRED_USE="|| ( X wayland )"
+
+COMMON_DEPEND="
+ >=app-accessibility/at-spi2-core-2.46.0:2
+ >=dev-libs/glib-2.50:2
+ >=dev-libs/libmateweather-1.17.0
+ dev-libs/libxml2:2
+ >=gnome-base/dconf-0.13.4
+ >=gnome-base/dconf-editor-43.0
+ >=mate-base/mate-desktop-1.17.0
+ >=mate-base/mate-menus-1.21.0
+ >=sys-apps/dbus-1.1.2
+ >=x11-libs/cairo-1.0.0[X?]
+ >=x11-libs/gdk-pixbuf-2.26.0:2
+ >=x11-libs/gtk+-3.22:3[introspection?]
+ x11-libs/libICE
+ x11-libs/libSM
+ >=x11-libs/libwnck-3.4.6:3[introspection?]
+ >=x11-libs/pango-1.15.4:0[introspection?]
+ X? (
+ x11-libs/libX11
+ x11-libs/libXau
+ >=x11-libs/libXrandr-1.3
+ )
+ introspection? ( >=dev-libs/gobject-introspection-0.6.7:= )
+ wayland? ( gui-libs/gtk-layer-shell )
+"
+
+RDEPEND="${COMMON_DEPEND}
+ virtual/libintl
+"
+
+DEPEND="${COMMON_DEPEND}"
+
+BDEPEND="
+ app-text/docbook-xml-dtd:4.1.2
+ app-text/yelp-tools
+ >=dev-lang/perl-5:=
+ dev-util/glib-utils
+ dev-util/gdbus-codegen
+ dev-util/gtk-doc
+ dev-build/gtk-doc-am
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_configure() {
+ mate_src_configure \
+ --libexecdir="${EPREFIX}"/usr/libexec/mate-applets \
+ --disable-deprecation-flags \
+ $(use_enable X x11) \
+ $(use_enable introspection) \
+ $(use_enable wayland)
+}