summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2023-05-03 08:13:02 -0400
committerMichael Orlitzky <mjo@gentoo.org>2023-05-04 10:02:29 -0400
commitd704bcaafc7999f3e6b21dbdf1963812c5f73456 (patch)
treeb87e9121baee3c032176e4ca1e05cb91ea95dc0c /mail-filter
parentdev-libs/rinutils: drop 0.10.1 (diff)
downloadgentoo-d704bcaafc7999f3e6b21dbdf1963812c5f73456.tar.gz
gentoo-d704bcaafc7999f3e6b21dbdf1963812c5f73456.tar.bz2
gentoo-d704bcaafc7999f3e6b21dbdf1963812c5f73456.zip
mail-filter/spf-engine: drop 2.9.3
Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'mail-filter')
-rw-r--r--mail-filter/spf-engine/Manifest1
-rw-r--r--mail-filter/spf-engine/spf-engine-2.9.3.ebuild77
2 files changed, 0 insertions, 78 deletions
diff --git a/mail-filter/spf-engine/Manifest b/mail-filter/spf-engine/Manifest
index a1a785990a37..f7084f23353b 100644
--- a/mail-filter/spf-engine/Manifest
+++ b/mail-filter/spf-engine/Manifest
@@ -1,2 +1 @@
-DIST spf-engine-2.9.3.tar.gz 52974 BLAKE2B 9e6c47af7d523e1486d9bbfee2b0e53a4a97dbfc93e1cd14f70d4676542defaf6fede397d33e21c00e9bb2cdd1016c98981b6c0e735bdfd225b226920b9470b1 SHA512 adde80eca38f372ad00ed7355951007b9c02ef8a52a5a4edcbf2fa9959220f1083e3e313668e9c7ad2c26144148ae8ff62ec468d79936d96b43897598254f528
DIST spf-engine-3.0.3.tar.gz 61350 BLAKE2B f28dfb10559bfd61be152a4b65a5653ec50b25718fcb63f8a2c9532fd9d52a51c131c99ba5408bd6aa424adc5ce6094da7eeb97dbacd7e60e8abb48c65c4f188 SHA512 08db392d2cce16651ba416fcd265e6606e1a8af3cb88721ed149a2286d11ac9ea6ed4d01572cea6950740890c3334e8e0d496d1d1e9edcc29d04833fec049ab0
diff --git a/mail-filter/spf-engine/spf-engine-2.9.3.ebuild b/mail-filter/spf-engine/spf-engine-2.9.3.ebuild
deleted file mode 100644
index bc923ece8954..000000000000
--- a/mail-filter/spf-engine/spf-engine-2.9.3.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYPI_NO_NORMALIZE=1
-PYTHON_COMPAT=( python3_9 python3_10 )
-
-# The built-in ipaddress module handles the parsing of IP addresses. If
-# python is built without ipv6 support, then ipaddress can't parse ipv6
-# addresses, and the daemon will crash if it sees an ipv6 SPF record. In
-# other words, it's completely broken.
-PYTHON_REQ_USE="ipv6(+)"
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Policy daemon and milter for Postfix SPF verification"
-HOMEPAGE="https://launchpad.net/spf-engine"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE=""
-
-DEPEND="dev-python/pyspf[${PYTHON_USEDEP}]"
-
-RDEPEND="${DEPEND}
- dev-python/authres[${PYTHON_USEDEP}]"
-
-DOCS=( CHANGES policyd-spf.conf.commented README README.per_user_whitelisting )
-
-python_prepare_all() {
- # The "real" config file mentions the commented one, so we point
- # users in the right direction.
- local oldconf="policyd-spf.conf.commented"
- local newconf="/usr/share/doc/${PF}/${oldconf}"
-
- sed -e "1 s~ ${oldconf}~,\n# ${newconf}~" -i policyd-spf.conf \
- || die 'failed to update commented config file path'
-
- distutils-r1_python_prepare_all
-}
-
-src_install() {
- distutils-r1_src_install
-
- # Remove the milter files that are installed by default. The milter
- # isn't quite ready:
- #
- # * The README says it's experimental not well-tested.
- # * There's no documentation for its configuration parameters
- # (expecially the UserID).
- # * The configuration file is hard-coded to /usr/local.
- # * The paths in the systemd service file are hard-coded to /usr/local.
- # * We need to write an OpenRC service script for it.
- #
- # These are all eventually doable, but I'm not willing to commit to
- # making the milter work before upstream is.
- #
- rm "${ED}/usr/bin/pyspf-milter" \
- || die "failed to remove ${ED}/usr/bin/pyspf-milter"
- rm -r "${ED}/usr/lib/systemd" \
- || die "failed to remove ${ED}/usr/lib/systemd"
- rm -r "${ED}/usr/etc/init.d" \
- || die "failed to remove ${ED}/usr/etc/init.d"
- einfo "The milter component of spf-engine is still deemed experimental"
- einfo "and not well-tested by upstream. It's missing configuration"
- einfo "files, service scripts, and documentation. In other words, it"
- einfo "doesn't work yet."
-
- # The setuptools installation routing always works relative to
- # python's prefix, so that when installing locally you wind up
- # with paths like /usr/local/etc. However for system installs
- # that does the wrong thing and puts the sysconfdir at /usr/etc.
- # Here we move it to the right place.
- mv -v "${ED}/usr/etc" "${ED}/" || die 'failed to relocate sysconfdir'
-}