summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /mail-filter/spampd
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'mail-filter/spampd')
-rw-r--r--mail-filter/spampd/Manifest2
-rw-r--r--mail-filter/spampd/files/conf15
-rw-r--r--mail-filter/spampd/files/init24
-rwxr-xr-xmail-filter/spampd/files/init-r124
-rw-r--r--mail-filter/spampd/metadata.xml8
-rw-r--r--mail-filter/spampd/spampd-2.30.ebuild24
-rw-r--r--mail-filter/spampd/spampd-2.42.ebuild26
7 files changed, 123 insertions, 0 deletions
diff --git a/mail-filter/spampd/Manifest b/mail-filter/spampd/Manifest
new file mode 100644
index 000000000000..7bf356032606
--- /dev/null
+++ b/mail-filter/spampd/Manifest
@@ -0,0 +1,2 @@
+DIST spampd-2.30.tar.gz 25001 SHA256 6885544f4d1b339ebe3ad58068434397280a6526f682e78f7d0246aef6a09979 SHA512 6f45016ef449e914bd23ddc1b9de508e7d068f198e587038de5b54dddb6ce4de451eca7f7e63a91e6a51423765fd971107a39a39c4f64e0ad1a37d5a885775f9 WHIRLPOOL 1d59bd2af47f546484f2aeecf02b3f151c579b9cb52daf423d28c56beb942a5f6c0dd2439f24a119703d035d4bfe313ec7b5951c6dd0ce7bbaa0e52c99151a64
+DIST spampd-2.42.tar.gz 202504 SHA256 c6dcef8df0c471b3982e777bcccfe343f1f6f921113c2b369a76144724b1d15d SHA512 5c44b5902efd6c628fb62887b755012b137940d7d687f5d9489e5f96623d6eeca5f3641a76fe3b2ce8585040c3661e19df981c612cdb1a767b4a46fec982fa4e WHIRLPOOL 6cd3ad9feac99d7bdd02d0824a7cb067a83c86f64552aa59ee9dabd021499bd75ff9e79bd10191e74f5887d8b6e461699970c61b832c7ee48976df61d191f54d
diff --git a/mail-filter/spampd/files/conf b/mail-filter/spampd/files/conf
new file mode 100644
index 000000000000..64abe21dd1b0
--- /dev/null
+++ b/mail-filter/spampd/files/conf
@@ -0,0 +1,15 @@
+# This is the configuration file that /etc/init.d/spampd sources when
+# started.
+
+# SPAMPD_OPTS defines the command-line arguments to be passed to the
+# spampd daemon upon start-up. A complete list of options can be
+# found in the documentation, or by issuing the command
+# "/usr/sbin/spampd --help"
+
+SPAMPD_OPTS="--host=localhost:10025 --relayhost=localhost:10026 --tagall"
+
+# Note: (from the Installation section in the spampd documentation)
+# "Note that spampd replaces spamd from the SpamAssassin distribution
+# in function. You do not need to run spamd in order for spampd to
+# work. This has apparently been the source of some confusion, so now
+# you know."
diff --git a/mail-filter/spampd/files/init b/mail-filter/spampd/files/init
new file mode 100644
index 000000000000..7fe788ca2117
--- /dev/null
+++ b/mail-filter/spampd/files/init
@@ -0,0 +1,24 @@
+#!/sbin/runscript
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+# Note: spampd configuration file is /etc/conf.d/spampd
+
+depend() {
+ use net
+}
+
+start() {
+ ebegin "Starting spampd"
+ start-stop-daemon --start --quiet \
+ --exec /usr/sbin/spampd -- --pid=/var/run/spampd.pid \
+ ${SPAMPD_OPTS}
+ eend $? "Failed to start spampd"
+}
+
+stop() {
+ ebegin "Stopping spampd"
+ start-stop-daemon --stop --quiet --pidfile /var/run/spampd.pid
+ eend $? "Failed to stop spampd"
+}
diff --git a/mail-filter/spampd/files/init-r1 b/mail-filter/spampd/files/init-r1
new file mode 100755
index 000000000000..de1996447b71
--- /dev/null
+++ b/mail-filter/spampd/files/init-r1
@@ -0,0 +1,24 @@
+#!/sbin/runscript
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+# Note: spampd configuration file is /etc/conf.d/spampd
+
+depend() {
+ use net
+}
+
+start() {
+ ebegin "Starting spampd"
+ start-stop-daemon --start --quiet \
+ --exec /usr/sbin/spampd.pl -- --pid=/run/spampd.pid \
+ ${SPAMPD_OPTS}
+ eend $? "Failed to start spampd"
+}
+
+stop() {
+ ebegin "Stopping spampd"
+ start-stop-daemon --stop --quiet --pidfile /run/spampd.pid
+ eend $? "Failed to stop spampd"
+}
diff --git a/mail-filter/spampd/metadata.xml b/mail-filter/spampd/metadata.xml
new file mode 100644
index 000000000000..6d2e935469e0
--- /dev/null
+++ b/mail-filter/spampd/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>net-mail</herd>
+ <upstream>
+ <remote-id type="github">mpaperno/spampd</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/mail-filter/spampd/spampd-2.30.ebuild b/mail-filter/spampd/spampd-2.30.ebuild
new file mode 100644
index 000000000000..12c5143e8578
--- /dev/null
+++ b/mail-filter/spampd/spampd-2.30.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+DESCRIPTION="spampd is a program to scan messages for possible Unsolicited Commercial E-mail content"
+HOMEPAGE="http://www.worlddesign.com/index.cfm/rd/mta/spampd.htm"
+SRC_URI="http://www.worlddesign.com/Content/rd/mta/${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc x86"
+IUSE=""
+
+RDEPEND="dev-lang/perl
+ dev-perl/net-server
+ mail-filter/spamassassin"
+DEPEND="${RDEPEND}"
+
+src_install() {
+ dosbin spampd
+ dodoc changelog.txt spampd-rh-rc-script
+ dohtml spampd.html
+ newinitd "${FILESDIR}"/init spampd
+ newconfd "${FILESDIR}"/conf spampd
+}
diff --git a/mail-filter/spampd/spampd-2.42.ebuild b/mail-filter/spampd/spampd-2.42.ebuild
new file mode 100644
index 000000000000..817550e88151
--- /dev/null
+++ b/mail-filter/spampd/spampd-2.42.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="spampd is a program to scan messages for possible Unsolicited Commercial E-mail content"
+HOMEPAGE="http://www.worlddesign.com/index.cfm/rd/mta/spampd.htm"
+SRC_URI="https://github.com/mpaperno/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="dev-lang/perl
+ dev-perl/net-server
+ mail-filter/spamassassin"
+DEPEND="${RDEPEND}"
+
+src_install() {
+ dosbin spampd.pl
+ dodoc changelog.txt misc/spampd-rh-rc-script.sh misc/spampd.service
+ dohtml spampd.html
+ newinitd "${FILESDIR}"/init-r1 spampd
+ newconfd "${FILESDIR}"/conf spampd
+}