summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2024-06-15 17:54:42 +0300
committerJimi Huotari <chiitoo@gentoo.org>2024-06-15 17:56:56 +0300
commit5ad3c2a73980512b863ed379864ebb7a0207b9c0 (patch)
tree8ae8ea68eb7a51e6bd74d2579abfd0ddc3e12f6c /lxqt-base/liblxqt
parentdev-python/mando: Enable py3.13 (diff)
downloadgentoo-5ad3c2a73980512b863ed379864ebb7a0207b9c0.tar.gz
gentoo-5ad3c2a73980512b863ed379864ebb7a0207b9c0.tar.bz2
gentoo-5ad3c2a73980512b863ed379864ebb7a0207b9c0.zip
lxqt-base/liblxqt: add qt6 USE dependency on polkit-qt
Closes: https://bugs.gentoo.org/934328 Signed-off-by: Jimi Huotari <chiitoo@gentoo.org>
Diffstat (limited to 'lxqt-base/liblxqt')
-rw-r--r--lxqt-base/liblxqt/liblxqt-2.0.0-r1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/lxqt-base/liblxqt/liblxqt-2.0.0-r1.ebuild b/lxqt-base/liblxqt/liblxqt-2.0.0-r1.ebuild
new file mode 100644
index 000000000000..d2b5f26ae54f
--- /dev/null
+++ b/lxqt-base/liblxqt/liblxqt-2.0.0-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Common base library for the LXQt desktop environment"
+HOMEPAGE="https://lxqt-project.org/"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="LGPL-2.1+ BSD"
+SLOT="0/$(ver_cut 1-2)"
+IUSE="+backlight"
+
+BDEPEND="
+ >=dev-qt/qttools-6.6:6[linguist]
+ >=dev-util/lxqt-build-tools-2.0.0
+"
+DEPEND="
+ >=dev-libs/libqtxdg-4.0.0
+ >=dev-qt/qtbase-6.6:6[dbus,gui,widgets,xml]
+ kde-frameworks/kwindowsystem:6[X]
+ x11-libs/libX11
+ x11-libs/libXScrnSaver
+ backlight? ( sys-auth/polkit-qt[qt6] )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_BACKLIGHT_LINUX_BACKEND=$(usex backlight)
+ )
+
+ cmake_src_configure
+}