summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-06-13 01:57:35 +0100
committerSam James <sam@gentoo.org>2024-06-13 01:59:48 +0100
commit3b4f3c13ff83e5a9b0470252393279b02c323d7f (patch)
treef5aba4e8de56c59f9b4ebce46d7873d1bd488cf6 /kde-plasma
parentkde-plasma/kwin: fix USE=systemd w/ libcxx (diff)
downloadgentoo-3b4f3c13ff83e5a9b0470252393279b02c323d7f.tar.gz
gentoo-3b4f3c13ff83e5a9b0470252393279b02c323d7f.tar.bz2
gentoo-3b4f3c13ff83e5a9b0470252393279b02c323d7f.zip
kde-plasma/plasma-meta: add ewarn for libc++
I still need to find someone to speak to about if we should implement the libc++ setting distro-wide (or someone else is free to do that). Bug: https://bugs.kde.org/479679 Bug: https://bugs.gentoo.org/923292 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'kde-plasma')
-rw-r--r--kde-plasma/plasma-meta/plasma-meta-6.0.90-r1.ebuild13
1 files changed, 13 insertions, 0 deletions
diff --git a/kde-plasma/plasma-meta/plasma-meta-6.0.90-r1.ebuild b/kde-plasma/plasma-meta/plasma-meta-6.0.90-r1.ebuild
index 65f6cd6ca2c5..c7d62908795b 100644
--- a/kde-plasma/plasma-meta/plasma-meta-6.0.90-r1.ebuild
+++ b/kde-plasma/plasma-meta/plasma-meta-6.0.90-r1.ebuild
@@ -3,6 +3,8 @@
EAPI=8
+inherit toolchain-funcs
+
DESCRIPTION="Merge this to pull in all Plasma 6 packages"
HOMEPAGE="https://kde.org/plasma-desktop/"
@@ -118,6 +120,17 @@ RDEPEND="${RDEPEND}
"
pkg_postinst() {
+ if [[ $(tc-get-cxx-stdlib) == "libc++" ]] ; then
+ # Workaround for bug #923292 (KDE-bug 479679)
+ ewarn "plasmashell and other KDE Plasma components are known to misbehave"
+ ewarn "when built with sys-libs/libcxx, e.g. crashing when right-clicking"
+ ewarn "on a panel. See bug #923292."
+ ewarn ""
+ ewarn "A possible (no warranty!) workaround is building sys-libs/libcxx and"
+ ewarn "sys-libs/libcxxabi with the following in package.env:"
+ ewarn " MYCMAKEARGS=\"-DLIBCXX_TYPEINFO_COMPARISON_IMPLEMENTATION=1\""
+ fi
+
if ! use qt5 && has_version dev-qt/qtgui; then
ewarn "KF5- and Qt5-based applications will exhibit various integration bugs"
ewarn "and generally look out of place in Plasma 6 without the dependencies"