summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-04-03 16:43:20 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-04-03 16:56:42 +0200
commit47b84fce9beb134c4584cf12e90a7a69f39eceb8 (patch)
treee3c7b82c0dbd39ddb6aac4df4cbb377e06cce878 /kde-plasma/kwallet-pam
parentdev-lang/python: ignore EPERM in test.support.unlink() (diff)
downloadgentoo-47b84fce9beb134c4584cf12e90a7a69f39eceb8.tar.gz
gentoo-47b84fce9beb134c4584cf12e90a7a69f39eceb8.tar.bz2
gentoo-47b84fce9beb134c4584cf12e90a7a69f39eceb8.zip
kde-plasma: Add KDE Plasma 5.18.4.1
Closes: https://bugs.gentoo.org/715884 Package-Manager: Portage-2.3.96, Repoman-2.3.22 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/kwallet-pam')
-rw-r--r--kde-plasma/kwallet-pam/Manifest1
-rw-r--r--kde-plasma/kwallet-pam/kwallet-pam-5.18.4.1.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/kde-plasma/kwallet-pam/Manifest b/kde-plasma/kwallet-pam/Manifest
index 2fbbbe8aa16f..88cdf0e0dcd0 100644
--- a/kde-plasma/kwallet-pam/Manifest
+++ b/kde-plasma/kwallet-pam/Manifest
@@ -1,2 +1,3 @@
DIST kwallet-pam-5.17.5.tar.xz 19712 BLAKE2B 2166498cddaabf55ea77312b96e863fe666afffe976507aa4f1c1421f7182c8db195d55b7462d3355acadb4cf2008792983712ec286811d22348ccdcc6cbfbbc SHA512 3a15ad62cb59aca1165c3159572669e5a44a2f1bb6aee51937b4d970a4eb901f7fbee74ed874ad20d65e3adb4009e143954dda1ee31ccd223c3a1b3208da6436
DIST kwallet-pam-5.18.3.tar.xz 19840 BLAKE2B 582f1c447dcb6f3d75904a85a56173541f9731356b356d1c434f6a7d3529fcf3f35adea928514bc7fbfe9068286dc0a58279b7a44bca8ca0807fa2d885fcd379 SHA512 dde5a6570f1d0e72cea6ce63491ddacd0b639cbcbb3fe90c4d3d26f8119a3597ae3fca889e179177bedd9cf4370190a8853bfcb5697430e417863570e92274e1
+DIST kwallet-pam-5.18.4.1.tar.xz 19840 BLAKE2B d5d6879b6fe71098eb92ca34a1c11424d590c7ff000f8b476b666fdd2ff09767aa3489ea9038d92375073815a42a73d08984851823f798099ae874f563a4536b SHA512 7be9fe57d29e3f03344cd477902c3d5ce9c19223645d1536502dbe2d6f74c0aede4435c997e6f9880bd3b44b865ee95579e64f73485dc6b6305143da44877b67
diff --git a/kde-plasma/kwallet-pam/kwallet-pam-5.18.4.1.ebuild b/kde-plasma/kwallet-pam/kwallet-pam-5.18.4.1.ebuild
new file mode 100644
index 000000000000..849263d4d766
--- /dev/null
+++ b/kde-plasma/kwallet-pam/kwallet-pam-5.18.4.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KFMIN=5.66.0
+PVCUT=$(ver_cut 1-3)
+inherit ecm kde.org
+
+DESCRIPTION="PAM module to not enter KWallet password again after login"
+
+LICENSE="LGPL-2.1"
+SLOT="5"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="
+ >=kde-frameworks/kwallet-${KFMIN}:5
+ dev-libs/libgcrypt:0=
+ sys-libs/pam
+"
+RDEPEND="${DEPEND}
+ net-misc/socat
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_LIBDIR="/$(get_libdir)"
+ )
+ ecm_src_configure
+}
+
+pkg_postinst() {
+ ecm_pkg_postinst
+ elog "This package enables auto-unlocking of kde-frameworks/kwallet:5."
+ elog "See also: https://wiki.gentoo.org/wiki/KDE#KWallet_auto-unlocking"
+}