summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-02-12 20:39:24 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-02-12 20:41:48 +0100
commit30026b45f60eff6506c3385a4c85c7d7b64958e5 (patch)
tree9047352a4c753df82973e1ce93ccb63904a2ae34 /kde-plasma/ksshaskpass
parentRevert "net-irc/irssi: Restore some random keywords" (diff)
downloadgentoo-30026b45f60eff6506c3385a4c85c7d7b64958e5.tar.gz
gentoo-30026b45f60eff6506c3385a4c85c7d7b64958e5.tar.bz2
gentoo-30026b45f60eff6506c3385a4c85c7d7b64958e5.zip
kde-plasma: Add KDE Plasma 5.15.0
Package-Manager: Portage-2.3.60, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/ksshaskpass')
-rw-r--r--kde-plasma/ksshaskpass/Manifest1
-rw-r--r--kde-plasma/ksshaskpass/ksshaskpass-5.15.0.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/kde-plasma/ksshaskpass/Manifest b/kde-plasma/ksshaskpass/Manifest
index 4b5b1860ec68..d152b1a74887 100644
--- a/kde-plasma/ksshaskpass/Manifest
+++ b/kde-plasma/ksshaskpass/Manifest
@@ -1 +1,2 @@
DIST ksshaskpass-5.14.5.tar.xz 21332 BLAKE2B a29b1fc2802925759eaf1b9ff8dec7dd0dddcf67b2093fd6b8a9bccb112264a9f01cbc8b42e707b9782cd3efe9d272ae9ca573e3e084f5a3dfe632d88be52104 SHA512 5517193df92ad868d06bcc8f353bfd38932d0a96d98e6af38d3714478233ea91771cbb7b075e76c133d595812643a0e2fea6a6086be94845a252c215b243b37f
+DIST ksshaskpass-5.15.0.tar.xz 21176 BLAKE2B b2c0f3f6f5ee8df0a67422d10e3c5ed607824b324a985e38350f5c6882044b290eaad55453f0e289c93fab2d570fc9702dfab2603cde090a6f866a6a68c20c38 SHA512 e32af4bbd10cce0b103ba5b7b1084115c3bd4c3133165119c45c553d21705ad337bd9559d8beb9b54223ae5028fcb651f8e8aa148dcc0ad4bcac5c87a3f177ba
diff --git a/kde-plasma/ksshaskpass/ksshaskpass-5.15.0.ebuild b/kde-plasma/ksshaskpass/ksshaskpass-5.15.0.ebuild
new file mode 100644
index 000000000000..dc9bad4320f1
--- /dev/null
+++ b/kde-plasma/ksshaskpass/ksshaskpass-5.15.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit kde5
+
+DESCRIPTION="KDE implementation of ssh-askpass with Kwallet integration"
+HOMEPAGE="https://cgit.kde.org/ksshaskpass.git"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+DEPEND="
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kwallet)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_qt_dep qtwidgets)
+"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ kde5_src_install
+
+ insinto /etc/plasma/startup
+ doins "${FILESDIR}/05-ksshaskpass.sh"
+}
+
+pkg_postinst() {
+ kde5_pkg_postinst
+
+ elog ""
+ elog "In order to have ssh-agent start at kde startup,"
+ elog "edit /etc/plasma/startup/10-agent-startup.sh and uncomment"
+ elog "the lines enabling ssh-agent."
+ elog
+ elog "If you do so, do not forget to uncomment the respective"
+ elog "lines in /etc/plasma/shutdown/10-agent-shutdown.sh to"
+ elog "properly kill the agent when the session ends."
+ elog
+ elog "${PN} has been installed as your default askpass application"
+ elog "for Plasma 5 sessions."
+ elog "If that's not desired, select the one you want to use in"
+ elog "/etc/plasma/startup/05-ksshaskpass.sh"
+ elog ""
+}