summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-04-02 20:21:46 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-04-02 23:05:24 +0200
commit55391d594cbb90254c591743415442484c3b0d02 (patch)
tree0495277eae519b0471a036e40a57ebd77d661530 /kde-plasma/kdeplasma-addons
parentdev-python/pillow: bump to 6.0.0 (diff)
downloadgentoo-55391d594cbb90254c591743415442484c3b0d02.tar.gz
gentoo-55391d594cbb90254c591743415442484c3b0d02.tar.bz2
gentoo-55391d594cbb90254c591743415442484c3b0d02.zip
kde-plasma: Add KDE Plasma 5.15.4
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/kdeplasma-addons')
-rw-r--r--kde-plasma/kdeplasma-addons/Manifest1
-rw-r--r--kde-plasma/kdeplasma-addons/kdeplasma-addons-5.15.4.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/kde-plasma/kdeplasma-addons/Manifest b/kde-plasma/kdeplasma-addons/Manifest
index 123e88aa5e81..36ebf7bedba6 100644
--- a/kde-plasma/kdeplasma-addons/Manifest
+++ b/kde-plasma/kdeplasma-addons/Manifest
@@ -1,2 +1,3 @@
DIST kdeplasma-addons-5.14.5.1.tar.xz 606580 BLAKE2B 1f8c60c16b1abc44dee8abac3d4b5fda14eb219ff077a392629d5893f06710e42edbbb47bd67a1a9d6d814b150932474dda38fa15eb3a23fab309e5f64b936c2 SHA512 3e755704d55755811b7eb9081022af3ae1bf743fb6a57007909fb46bdae1851b488e08dcccaa8bc3683fa050d8d2612c9520d4e1bb2deb1cf31fcf22610d7ce2
DIST kdeplasma-addons-5.15.3.tar.xz 603136 BLAKE2B 34cb66231ac30ef6a9deda8eb4e1f9a06a199e13e0b32571705044fd5dc486f1f97f5e216c3958fe511b99432f6119dd5ae31991a8daf5e3e470d5162bc0fc99 SHA512 423405fdcbf584bb738be77a6a4456c6f6bcf68418e77742ad6606e8dece146eff0891cdb0128765b757ecb6a4dcee37c01ffaf2fdc87c3f574fb880ed85bd48
+DIST kdeplasma-addons-5.15.4.tar.xz 604968 BLAKE2B eb0d5766c39bc0580eab79b5cf1cef92f373a28eb7e24da7fab2ee6e683a64dd446ec0e9a4efcea801161a48120cbd1aa359a376e9267d8960d52280043ce1d2 SHA512 cbc459deae600687fbce2d21a3e9a47d62518fff4636ca1d0c3088a35570e788879bc44659a6a0e51940637002d6e5cff3324320be801d50d4bc0d874f4da706
diff --git a/kde-plasma/kdeplasma-addons/kdeplasma-addons-5.15.4.ebuild b/kde-plasma/kdeplasma-addons/kdeplasma-addons-5.15.4.ebuild
new file mode 100644
index 000000000000..0d8ba38af27c
--- /dev/null
+++ b/kde-plasma/kdeplasma-addons/kdeplasma-addons-5.15.4.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit kde5
+
+DESCRIPTION="Extra Plasma applets and engines"
+LICENSE="GPL-2 LGPL-2"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="share webengine"
+
+DEPEND="
+ $(add_frameworks_dep karchive)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcmutils)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdeclarative)
+ $(add_frameworks_dep kholidays)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep knewstuff)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kpackage)
+ $(add_frameworks_dep kross)
+ $(add_frameworks_dep krunner)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kunitconversion)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep kxmlgui)
+ $(add_frameworks_dep plasma)
+ $(add_frameworks_dep sonnet)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtdeclarative)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ share? ( $(add_frameworks_dep purpose) )
+ webengine? ( $(add_qt_dep qtwebengine) )
+"
+RDEPEND="${DEPEND}
+ $(add_plasma_dep plasma-workspace)
+ $(add_qt_dep qtquickcontrols)
+ $(add_qt_dep qtquickcontrols2)
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package share KF5Purpose)
+ $(cmake-utils_use_find_package webengine Qt5WebEngine)
+ )
+
+ kde5_src_configure
+}