summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-01-14 23:03:04 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2024-01-14 23:28:04 +0100
commit958fd8716ce2623f79d61d043ce81bde69f9ddbf (patch)
tree2a233101cfeab810391e13a3e8bc7348d1278345 /kde-frameworks
parentkde-frameworks/ktextwidgets: 5.114.0 version bump (diff)
downloadgentoo-958fd8716ce2623f79d61d043ce81bde69f9ddbf.tar.gz
gentoo-958fd8716ce2623f79d61d043ce81bde69f9ddbf.tar.bz2
gentoo-958fd8716ce2623f79d61d043ce81bde69f9ddbf.zip
kde-frameworks/kwallet: 5.114.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks')
-rw-r--r--kde-frameworks/kwallet/Manifest1
-rw-r--r--kde-frameworks/kwallet/kwallet-5.114.0.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/kde-frameworks/kwallet/Manifest b/kde-frameworks/kwallet/Manifest
index eb30ebb1f42d..d8b6bb423594 100644
--- a/kde-frameworks/kwallet/Manifest
+++ b/kde-frameworks/kwallet/Manifest
@@ -1,2 +1,3 @@
DIST kwallet-5.113.0.tar.xz 351656 BLAKE2B 00c1adef54bfd9a662c5aa2ad8d237f0bf9b31d5adcb78338f1d7cdbe4d8de25e596e10efcbbbfa68657d6f557936bcace7ad95e8d90d735b79b8b87da304758 SHA512 7f7ce975056b34161e2038ec88a371d1e12913d68cbbe6b3069a5ce4ced9a75f7e82e23ec38c929da6d4ce8dc8e863d32237b80bc47c6ecedaeee8cee42c86ce
+DIST kwallet-5.114.0.tar.xz 351784 BLAKE2B 74df2c935bb7e8e4e703004521542e366867060092fb1045b5a727f74e1adbb777792d6d8d9b30df49d7cf12c2a61ce92d70b912c388094540e8294d5aad2b25 SHA512 22077495cd5d00f159017c52080e7d3a471d2434305fad412dfc1cb8528e196a1fa88a315f31f4a90d7b459307f1e45ae025e293f88774842e995ea52234d1a5
DIST kwallet-5.248.0.tar.xz 350112 BLAKE2B d38ed0ddc37eb1c78cfa080bd3d644b68276e9d69adce202bc5d57aa00441347cc7fcb2226df59f1803ddb3823b758fe7fa580731f33791c3c4358daa1320c13 SHA512 08a052bbdb1285a8ada9deb9ae5487a0e121dcefd65f4904d0099f5c7323da00129c104c05c0075b82d5c4faef75faa567a38b084ba6ed4921d88945b478cb78
diff --git a/kde-frameworks/kwallet/kwallet-5.114.0.ebuild b/kde-frameworks/kwallet/kwallet-5.114.0.ebuild
new file mode 100644
index 000000000000..422b94f04d8d
--- /dev/null
+++ b/kde-frameworks/kwallet/kwallet-5.114.0.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.15.9
+inherit ecm frameworks.kde.org optfeature
+
+DESCRIPTION="Framework providing desktop-wide storage for passwords"
+
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE="gpg kf6compat +man"
+
+DEPEND="
+ >=app-crypt/qca-2.3.1:2[qt5(+)]
+ dev-libs/libgcrypt:0=
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ =kde-frameworks/kconfig-${PVCUT}*:5
+ =kde-frameworks/kconfigwidgets-${PVCUT}*:5
+ =kde-frameworks/kcoreaddons-${PVCUT}*:5
+ =kde-frameworks/kdbusaddons-${PVCUT}*:5
+ =kde-frameworks/ki18n-${PVCUT}*:5
+ =kde-frameworks/knotifications-${PVCUT}*:5
+ =kde-frameworks/kservice-${PVCUT}*:5
+ =kde-frameworks/kwidgetsaddons-${PVCUT}*:5
+ =kde-frameworks/kwindowsystem-${PVCUT}*:5[X]
+ !kf6compat? ( gpg? ( >=app-crypt/gpgme-1.7.1:=[cxx,qt5] ) )
+"
+RDEPEND="${DEPEND}
+ kf6compat? ( kde-frameworks/kwallet:6 )
+"
+BDEPEND="man? ( >=kde-frameworks/kdoctools-${PVCUT}:5 )"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_KWALLETD=$(usex !kf6compat)
+ -DBUILD_KWALLET_QUERY=$(usex !kf6compat)
+ $(cmake_use_find_package man KF5DocTools)
+ )
+ if ! use kf6compat; then
+ mycmakeargs+=(
+ $(cmake_use_find_package gpg Gpgmepp)
+ )
+ fi
+
+ ecm_src_configure
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ optfeature "Auto-unlocking after account login" "kde-plasma/kwallet-pam:5"
+ optfeature "KWallet management" "kde-apps/kwalletmanager:5"
+ elog "For more information, read https://wiki.gentoo.org/wiki/KDE#KWallet"
+ fi
+ ecm_pkg_postinst
+}