summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-08-11 00:21:01 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-08-11 10:19:23 +0200
commit832934f31e45d450d2eaee2a9ebd501303303c43 (patch)
tree26ddfbcde55dc86490c71053a6813be8c3a8c212 /kde-frameworks/kcrash
parentmedia-gfx/digikam: Drop 6.1.0 (diff)
downloadgentoo-832934f31e45d450d2eaee2a9ebd501303303c43.tar.gz
gentoo-832934f31e45d450d2eaee2a9ebd501303303c43.tar.bz2
gentoo-832934f31e45d450d2eaee2a9ebd501303303c43.zip
kde-frameworks: Add KDE Frameworks 5.61.0
Package-Manager: Portage-2.3.71, Repoman-2.3.17 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/kcrash')
-rw-r--r--kde-frameworks/kcrash/Manifest1
-rw-r--r--kde-frameworks/kcrash/kcrash-5.61.0.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/kde-frameworks/kcrash/Manifest b/kde-frameworks/kcrash/Manifest
index 3a73c4b4a95b..42c09c84247f 100644
--- a/kde-frameworks/kcrash/Manifest
+++ b/kde-frameworks/kcrash/Manifest
@@ -1 +1,2 @@
DIST kcrash-5.60.0.tar.xz 23036 BLAKE2B 415390db9305106b977baed72342d1cccd97d9d814876fdf01cd8e481882586fc61477acc0bbb4710a39f43fc8c8d8b7b283ba68ca1b899c7c4b7f5fd7c37d8e SHA512 21404a5cfc48b2a4b2b901765a7a763b05932214dc7d568cf81378e02526954fd708c648d9c51136eb12880d57a94e7f42c64af93a3ce81eb6af41a0ce42027d
+DIST kcrash-5.61.0.tar.xz 22968 BLAKE2B 4a119dd586702c59a5646135f2a9148af7d2300c2035551e2876268c11fd0b9884ab0372fad3fa2a40dbe315ae9422b431df63fa4d7077d83e1bad524b000875 SHA512 982375a7376c70a89beba2da10efa56f7f6645bfa3dd7a063d13a7a67c317836597b3c732216ada4d6e896f817ed8f1569fd49462db82dba9369fd4811fe2741
diff --git a/kde-frameworks/kcrash/kcrash-5.61.0.ebuild b/kde-frameworks/kcrash/kcrash-5.61.0.ebuild
new file mode 100644
index 000000000000..59a1d61a4977
--- /dev/null
+++ b/kde-frameworks/kcrash/kcrash-5.61.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Framework for intercepting and handling application crashes"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="nls"
+
+# requires running kde environment
+RESTRICT+=" test"
+
+BDEPEND="
+ nls? ( $(add_qt_dep linguist-tools) )
+"
+RDEPEND="
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtx11extras)
+ x11-libs/libX11
+"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto
+ test? ( $(add_qt_dep qtwidgets) )
+"