summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-09-12 22:51:52 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-09-13 07:18:33 +0200
commitfaac74f1eb7d4b2d6871a9563a4814f6b85f00bf (patch)
tree655a4d2fa54aaa7174d2d3d09372d707bff55ff7 /kde-frameworks/frameworkintegration
parentdev-libs/plasma-wayland-protocols: 1.4.0 version bump (diff)
downloadgentoo-faac74f1eb7d4b2d6871a9563a4814f6b85f00bf.tar.gz
gentoo-faac74f1eb7d4b2d6871a9563a4814f6b85f00bf.tar.bz2
gentoo-faac74f1eb7d4b2d6871a9563a4814f6b85f00bf.zip
kde-frameworks/frameworkintegration: 5.86.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/frameworkintegration')
-rw-r--r--kde-frameworks/frameworkintegration/Manifest1
-rw-r--r--kde-frameworks/frameworkintegration/frameworkintegration-5.86.0.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/kde-frameworks/frameworkintegration/Manifest b/kde-frameworks/frameworkintegration/Manifest
index 23dda9b73b93..2dde14fb99a1 100644
--- a/kde-frameworks/frameworkintegration/Manifest
+++ b/kde-frameworks/frameworkintegration/Manifest
@@ -1,2 +1,3 @@
DIST frameworkintegration-5.82.0.tar.xz 1755828 BLAKE2B 18c056daf8db8e06995d3f0b6985f9aabb05e8a4e7323635faf92701f04dbf135cf63221fe739504d2ccd7718dd02a6718ab7fa7ba84b86cb37394ff878b6e3f SHA512 5865e560789c50829c5648365db58497d0da141d1699f396ca431740e6f919ef68c89e2cb98ac1f320cdb07fae098de683b17c920f79a2b459ffd874935b6e77
DIST frameworkintegration-5.85.0.tar.xz 1755792 BLAKE2B 0a9b6b9a35d20fac0d07cbcf23f4ca1e0627a0175a7298a6b6391b1f4e1c38a46e029dc21ff22ea397ad3de053485097137e5a0de818300000f0c0e4f03c474e SHA512 d496c3b2ff49a3e4ee43e3c208b7dd3df68561fed0fe519f22a163c3389683f7d776270fc6472f4b52677cf85eb4a73c6bb7bdeea951600f8f5302411677a4f3
+DIST frameworkintegration-5.86.0.tar.xz 1755804 BLAKE2B f5100b577fc3664d34ae0e62f1c05763eba173595aaf86b7bb073a69c3baa126c7fae34e07e72a541f2da79063ea6cbf101c43294eca65ad545e37a8f2245ed6 SHA512 66a97064a47599e27ec5fc7ac92be87a5c7df31154f662d13bcd21556562b50989b82ab538ae96b7f372a2ee77c408e47ffed62bff1c94c91f8b2b9c786dec69
diff --git a/kde-frameworks/frameworkintegration/frameworkintegration-5.86.0.ebuild b/kde-frameworks/frameworkintegration/frameworkintegration-5.86.0.ebuild
new file mode 100644
index 000000000000..d52fad501353
--- /dev/null
+++ b/kde-frameworks/frameworkintegration/frameworkintegration-5.86.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_QTHELP="false"
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.15.2
+VIRTUALX_REQUIRED="test"
+inherit ecm kde.org
+
+DESCRIPTION="Framework for integrating Qt applications with KDE Plasma workspaces"
+
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+IUSE=""
+
+# requires running Plasma environment
+RESTRICT="test"
+
+RDEPEND="
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ =kde-frameworks/kconfig-${PVCUT}*:5
+ =kde-frameworks/kconfigwidgets-${PVCUT}*:5
+ =kde-frameworks/ki18n-${PVCUT}*:5
+ =kde-frameworks/kiconthemes-${PVCUT}*:5
+ =kde-frameworks/knewstuff-${PVCUT}*:5
+ =kde-frameworks/knotifications-${PVCUT}*:5
+"
+DEPEND="${RDEPEND}
+ =kde-frameworks/kpackage-${PVCUT}*:5
+ =kde-frameworks/kwidgetsaddons-${PVCUT}*:5
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_DISABLE_FIND_PACKAGE_AppStreamQt=ON
+ -DCMAKE_DISABLE_FIND_PACKAGE_packagekitqt5=ON
+ )
+
+ ecm_src_configure
+}