summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-10-12 16:10:58 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2017-10-12 16:18:26 +0200
commita6d3a93f1f50f5797b4d119f529dffcaf0d3a1e4 (patch)
tree4d3ec8ddaa83500e5b7b78a9fdbb5d4fd20540d5 /kde-apps/step
parentkde-frameworks/kdelibs: 4.14.37 version bump (diff)
downloadgentoo-a6d3a93f1f50f5797b4d119f529dffcaf0d3a1e4.tar.gz
gentoo-a6d3a93f1f50f5797b4d119f529dffcaf0d3a1e4.tar.bz2
gentoo-a6d3a93f1f50f5797b4d119f529dffcaf0d3a1e4.zip
kde-apps: Add KDE Applications 17.08.2
Package-Manager: Portage-2.3.11, Repoman-2.3.3
Diffstat (limited to 'kde-apps/step')
-rw-r--r--kde-apps/step/Manifest1
-rw-r--r--kde-apps/step/step-17.08.2.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/kde-apps/step/Manifest b/kde-apps/step/Manifest
index 63d0e315e680..aa1264c2c368 100644
--- a/kde-apps/step/Manifest
+++ b/kde-apps/step/Manifest
@@ -1,2 +1,3 @@
DIST step-17.04.3.tar.xz 861708 SHA256 7a2ef0548bae9dcf370d818fa527fba232ba84da84a6664cce114e0492c53784 SHA512 7b32e5dfcaf1b300daf72955af9cdf2bd2d793905ddf18483f35e4dbd2f257b362979a6ce0182e5335c809bec07b7aff08f2b353cfc937d1a386df4eeda3bdfa WHIRLPOOL 61f865e33e8e1b3a8c47c8c2b2a256a9d6e15e5b99393a8a5fd1289e21c669ee5bdde7b8d9b739518fb997de4c0fb0e003324388ebcdb2a91adb1d041da7edbf
DIST step-17.08.1.tar.xz 860056 SHA256 ea45c152a6e18765bd87460a16e19c1ffc9f100906d3121e0042900a5ecbe986 SHA512 f82e646fa19bd96fdd410ed60e521fccf04c544aa4e99332ff0d2acc382d91187ab3d6a54b5d21c172fa1f8e2556e444420608170102de1384bba6574c11e609 WHIRLPOOL f1c0b7871d58ba9f54451615f0035479ef7b14434612ef991f2ea5ef879399f5d33091916946e850a2bab01a542c4ead946fac80b0dda5b52e7ca5e5e69fc952
+DIST step-17.08.2.tar.xz 859712 SHA256 f32769d3db93ecb1fa5beb0955d0b2fe0e0889deefa3ba32106ea7b1cc798a52 SHA512 65e2f28fa5245736a2ab049fc007b0955bf3c136206e7591016f3eaa8099c3ff37974a832274d111ab0c59bd5d24055bdd73ef6b75184752d309e99672c96bb4 WHIRLPOOL 51b882fce51a224af1507b7d80bf9066f1eafe547d136c04ba14b09fac3c7d029a59b8d37bce93c9906fdff343ec8d50ba259cf8a29d93bf51dc12199fd77653
diff --git a/kde-apps/step/step-17.08.2.ebuild b/kde-apps/step/step-17.08.2.ebuild
new file mode 100644
index 000000000000..c121e41b44ed
--- /dev/null
+++ b/kde-apps/step/step-17.08.2.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_HANDBOOK="forceoptional" # not optional until !kdelibs4support
+KDE_TEST="forceoptional"
+inherit kde5
+
+DESCRIPTION="Interactive physics simulator"
+HOMEPAGE="https://edu.kde.org/step"
+KEYWORDS="~amd64 ~x86"
+IUSE="+gsl nls +qalculate"
+
+RDEPEND="
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kcrash)
+ $(add_frameworks_dep kdelibs4support)
+ $(add_frameworks_dep khtml)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep knewstuff)
+ $(add_frameworks_dep kparts)
+ $(add_frameworks_dep kplotting)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep ktextwidgets)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_qt_dep qtdeclarative)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtopengl)
+ $(add_qt_dep qtprintsupport)
+ $(add_qt_dep qtsvg)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+ >=dev-cpp/eigen-3.2:3
+ sci-libs/cln
+ gsl? ( sci-libs/gsl:= )
+ qalculate? ( >=sci-libs/libqalculate-0.9.5:= )
+"
+DEPEND="${RDEPEND}
+ nls? ( $(add_qt_dep linguist-tools) )
+"
+
+src_prepare() {
+ kde5_src_prepare
+
+ # FIXME: Drop duplicate upstream
+ sed -e '/find_package.*Xml Test/ s/^/#/' \
+ -i stepcore/CMakeLists.txt || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package gsl GSL)
+ $(cmake-utils_use_find_package qalculate Qalculate)
+ )
+ kde5_src_configure
+}