summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-01-10 09:30:23 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-01-10 16:50:00 +0100
commitf1b6a4697cb6bd8b01b005cca0996982fd736a2d (patch)
tree9b2799b0df1355e0ee40b8c909752698a0803837 /kde-apps/libkgeomap
parentapp-emulation/libvirt: init submodules for live ebuild (diff)
downloadgentoo-f1b6a4697cb6bd8b01b005cca0996982fd736a2d.tar.gz
gentoo-f1b6a4697cb6bd8b01b005cca0996982fd736a2d.tar.bz2
gentoo-f1b6a4697cb6bd8b01b005cca0996982fd736a2d.zip
kde-apps: Add KDE Applications 18.12.1
Package-Manager: Portage-2.3.54, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/libkgeomap')
-rw-r--r--kde-apps/libkgeomap/Manifest1
-rw-r--r--kde-apps/libkgeomap/libkgeomap-18.12.1.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/kde-apps/libkgeomap/Manifest b/kde-apps/libkgeomap/Manifest
index e1b51874ac5c..1153d67a6cc2 100644
--- a/kde-apps/libkgeomap/Manifest
+++ b/kde-apps/libkgeomap/Manifest
@@ -1,2 +1,3 @@
DIST libkgeomap-18.08.3.tar.xz 150976 BLAKE2B e9e7c85e2c4711fb6a68829644de2e99b47c417f915cf734928da1d93590a2b61faeef4b895d970c403dc40e844274e73204ba4fb00164fb295d13a43cd442e0 SHA512 d7b014085ba2a89d77802202878c58286307c20c25a024d748aa1271b61c7f31ade7e066f02bf44f66fbc6ab85f5cd176e09a21fbca45a3095096b4cee9ca275
DIST libkgeomap-18.12.0.tar.xz 151164 BLAKE2B ed83f92021363c1538b8501efc1b4a90f671a1127ff6f5118e61fd8a63fa8576d31ff96b42a5929c10c86e7ff18de6af8fe799152fb593983216fc886c336d84 SHA512 26cc0e96dafdae906d5f30a4e06cf39ad97972785064b615171124c38f006c9e8828c3ed5bba42afa85a7d7172cbd70c2878b60f77207349e43c3620848727a0
+DIST libkgeomap-18.12.1.tar.xz 151076 BLAKE2B 5ee1d29254a6ac1b101e639eedeeca5a9b944f4c617eee440789c8086423f49cb1d7d0b9361d1ad1d488a82a97e581c14f228a0f4ccc640f2f6da52a45091b36 SHA512 d63b99e12d6b38fae5d6b73a512242304acd65f0486801a1d881009d2328f8764eb33004d4c90aae435be34650b07cbdb114e1c3d28cbfd6d50351a4c8f3676b
diff --git a/kde-apps/libkgeomap/libkgeomap-18.12.1.ebuild b/kde-apps/libkgeomap/libkgeomap-18.12.1.ebuild
new file mode 100644
index 000000000000..3970ea2d41ae
--- /dev/null
+++ b/kde-apps/libkgeomap/libkgeomap-18.12.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_TEST="true"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Wrapper library for world map components as marble, openstreetmap and googlemap"
+HOMEPAGE="https://www.digikam.org/"
+
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kio)
+ $(add_kdeapps_dep marble 'kde' '' '5=')
+ $(add_qt_dep qtconcurrent)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwebkit)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_DISABLE_FIND_PACKAGE_KF5KExiv2=true
+ )
+
+ kde5_src_configure
+}