summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-07-03 18:52:57 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2024-07-04 13:50:14 +0200
commit29980f88688c640ef87da5420b26085adba289b4 (patch)
tree0401bb56c977f47f312a9a3ed694f997c523104f /kde-apps/kolourpaint
parentkde-apps/kdegraphics-mobipocket: 24.05.2 version bump (diff)
downloadgentoo-29980f88688c640ef87da5420b26085adba289b4.tar.gz
gentoo-29980f88688c640ef87da5420b26085adba289b4.tar.bz2
gentoo-29980f88688c640ef87da5420b26085adba289b4.zip
kde-apps/kolourpaint: 24.05.2 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/kolourpaint')
-rw-r--r--kde-apps/kolourpaint/Manifest1
-rw-r--r--kde-apps/kolourpaint/kolourpaint-24.05.2.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/kde-apps/kolourpaint/Manifest b/kde-apps/kolourpaint/Manifest
index 572034b2cda6..2fc90e04d63f 100644
--- a/kde-apps/kolourpaint/Manifest
+++ b/kde-apps/kolourpaint/Manifest
@@ -1,2 +1,3 @@
DIST kolourpaint-24.02.2.tar.xz 5796724 BLAKE2B 6b06a86174d98a0cfea339cf42fe875163c3ee697837c7ccdb9a4c234c74e6d980487fde3072871e17b56ad17180f6983566884f902bd1f4f73f584aedc9f577 SHA512 4277ba48582a1ee3c62e95e00f4d8c3e048348eab5e2d75f0579e5e4b179da85793d6cf744b423c3991e9c6501fa4f9d78bfb8fa7389b9e9f334eb61a78000e0
DIST kolourpaint-24.05.1.tar.xz 5294944 BLAKE2B f6e604fc2a2ca8a8ca7dab5f7572085bb9a7b3b44a90385ebbecc5c7b270d77b9f847f1167c831d08004e4519ec60369d73d5baae1c707d18cef083d5861d1d1 SHA512 a9d530cc7dc6c00d90614e3422609ab226df9b2318834263810c51cc2ea59462d01582f95e3963366d62e71aa7f519bba6babbdcc04d48c01e9f0b8041b5d694
+DIST kolourpaint-24.05.2.tar.xz 5294868 BLAKE2B 54b42452fa98fe3a45e48bc5f9658770a6ed5301408afc2c8a8d1b497c88608af9f34936b071d255c3cb5bebf46ff13fdad47be3283f833c8a1e55505485cf52 SHA512 9133693c46a209486b896e8d007fd4733355eef201cb0067557b3d6a2d4bf2f8785d0bf7f27e431b51b20485f27f1c0c334a9abeaf2215bb4caf33c64fb22191
diff --git a/kde-apps/kolourpaint/kolourpaint-24.05.2.ebuild b/kde-apps/kolourpaint/kolourpaint-24.05.2.ebuild
new file mode 100644
index 000000000000..c086af6fffd1
--- /dev/null
+++ b/kde-apps/kolourpaint/kolourpaint-24.05.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_HANDBOOK="forceoptional"
+PVCUT=$(ver_cut 1-3)
+KFMIN=6.3.0
+QTMIN=6.6.2
+inherit ecm gear.kde.org
+
+DESCRIPTION="Paint Program by KDE"
+HOMEPAGE="https://apps.kde.org/kolourpaint/"
+
+LICENSE="BSD-2 LGPL-2 LGPL-2+ || ( LGPL-2.1 LGPL-3 ) GPL-2 handbook? ( FDL-1.2 )"
+SLOT="6"
+KEYWORDS="~amd64 ~arm64"
+IUSE="scanner"
+
+DEPEND="
+ >=dev-qt/qtbase-${QTMIN}:6[gui,widgets]
+ >=kde-frameworks/kconfig-${KFMIN}:6
+ >=kde-frameworks/kconfigwidgets-${KFMIN}:6
+ >=kde-frameworks/kcoreaddons-${KFMIN}:6
+ >=kde-frameworks/kguiaddons-${KFMIN}:6
+ >=kde-frameworks/ki18n-${KFMIN}:6
+ >=kde-frameworks/kio-${KFMIN}:6
+ >=kde-frameworks/kjobwidgets-${KFMIN}:6
+ >=kde-frameworks/kservice-${KFMIN}:6
+ >=kde-frameworks/ktextwidgets-${KFMIN}:6
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:6
+ >=kde-frameworks/kxmlgui-${KFMIN}:6
+ scanner? ( >=kde-apps/libksane-${PVCUT}:6 )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package scanner KF6Sane)
+ )
+
+ ecm_src_configure
+}