summaryrefslogtreecommitdiff
path: root/gui-wm
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2022-12-25 12:44:38 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2022-12-25 12:51:17 -0600
commit2a1755fff1492f760da054c914434f11f7f98599 (patch)
treebe587eec65e77e0378d00558dfb09b127094e23c /gui-wm
parentgui-libs/wlroots: add 0.16.1 (diff)
downloadgentoo-2a1755fff1492f760da054c914434f11f7f98599.tar.gz
gentoo-2a1755fff1492f760da054c914434f11f7f98599.tar.bz2
gentoo-2a1755fff1492f760da054c914434f11f7f98599.zip
gui-wm/sway: 1.8 bump
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'gui-wm')
-rw-r--r--gui-wm/sway/Manifest1
-rw-r--r--gui-wm/sway/sway-1.8.ebuild115
-rw-r--r--gui-wm/sway/sway-9999.ebuild4
3 files changed, 119 insertions, 1 deletions
diff --git a/gui-wm/sway/Manifest b/gui-wm/sway/Manifest
index e84c828992a9..bc7edc11c748 100644
--- a/gui-wm/sway/Manifest
+++ b/gui-wm/sway/Manifest
@@ -1 +1,2 @@
DIST sway-1.7.tar.gz 5559075 BLAKE2B 702b9a209d603c88743f2e89d0787431b7a30e8b7554c9596edb9735af862d23c585158737a0943a470637138cbc5275bee37bd2d820a7489cdd0747d98e6e22 SHA512 028cf5d504d5914bfb78d44156d6a290de660c5ed0638f4e2c56e5be76db9b0baeda035e1fa1ae23559016bd7e4312f7ff70c2fb4904df25358577c1a3d21243
+DIST sway-1.8.tar.gz 5577138 BLAKE2B cf93db2d7722be5a14f3557087c8298cbbbaa7268ffb8540c5473581200323b6ba24c9a669e2b7fb31afe3cbe49314eef9f224c438ad3c4cd93ef939285be365 SHA512 9f4f24ecc16c2ffe0e2b17fa5f0da871493073fc96f2daf20323459b3adfb29bae3c369833d713ae254b5ac036d9b6625f76595ca31c3d216626095d1ef29615
diff --git a/gui-wm/sway/sway-1.8.ebuild b/gui-wm/sway/sway-1.8.ebuild
new file mode 100644
index 000000000000..8468aba7acc3
--- /dev/null
+++ b/gui-wm/sway/sway-1.8.ebuild
@@ -0,0 +1,115 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson optfeature
+
+DESCRIPTION="i3-compatible Wayland window manager"
+HOMEPAGE="https://swaywm.org"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/swaywm/${PN}.git"
+else
+ MY_PV=${PV/_rc/-rc}
+ SRC_URI="https://github.com/swaywm/${PN}/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~loong ~ppc64 ~riscv ~x86"
+ S="${WORKDIR}/${PN}-${MY_PV}"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="grimshot +man +swaybar +swaynag tray wallpapers X"
+
+DEPEND="
+ >=dev-libs/json-c-0.13:0=
+ >=dev-libs/libinput-1.21.0:0=
+ sys-auth/seatd:=
+ dev-libs/libpcre2
+ >=dev-libs/wayland-1.20.0
+ x11-libs/cairo
+ x11-libs/libxkbcommon
+ x11-libs/pango
+ x11-libs/pixman
+ x11-libs/xcb-util-wm
+ media-libs/mesa[gles2,libglvnd(+)]
+ swaybar? ( x11-libs/gdk-pixbuf:2 )
+ tray? ( || (
+ sys-apps/systemd
+ sys-auth/elogind
+ sys-libs/basu
+ ) )
+ wallpapers? ( gui-apps/swaybg[gdk-pixbuf(+)] )
+ X? ( x11-libs/libxcb:0= )
+"
+# x11-libs/xcb-util-wm needed for xcb-iccm
+if [[ ${PV} == 9999 ]]; then
+ DEPEND+="~gui-libs/wlroots-9999:=[X?]"
+else
+ DEPEND+="
+ >=gui-libs/wlroots-0.16:=[X?]
+ <gui-libs/wlroots-0.17:=[X?]
+ "
+fi
+RDEPEND="
+ x11-misc/xkeyboard-config
+ grimshot? (
+ app-misc/jq
+ gui-apps/grim
+ gui-apps/slurp
+ gui-apps/wl-clipboard
+ x11-libs/libnotify
+ )
+ ${DEPEND}
+"
+BDEPEND="
+ >=dev-libs/wayland-protocols-1.24
+ >=dev-util/meson-0.60.0
+ virtual/pkgconfig
+"
+if [[ ${PV} == 9999 ]]; then
+ BDEPEND+="man? ( ~app-text/scdoc-9999 )"
+else
+ BDEPEND+="man? ( >=app-text/scdoc-1.9.3 )"
+fi
+REQUIRED_USE="tray? ( swaybar )"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature man man-pages)
+ $(meson_feature tray)
+ $(meson_feature X xwayland)
+ $(meson_feature swaybar gdk-pixbuf)
+ $(meson_use swaynag)
+ $(meson_use swaybar)
+ $(meson_use wallpapers default-wallpaper)
+ -Dfish-completions=true
+ -Dzsh-completions=true
+ -Dbash-completions=true
+ )
+
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+
+ if use grimshot; then
+ doman contrib/grimshot.1
+ dobin contrib/grimshot
+ fi
+}
+
+pkg_postinst() {
+ optfeature_header "There are several packages that may be useful with sway:"
+ optfeature "wallpaper utility" gui-apps/swaybg
+ optfeature "idle management utility" gui-apps/swayidle
+ optfeature "simple screen locker" gui-apps/swaylock
+ optfeature "lightweight notification daemon" gui-apps/mako
+ echo
+ einfo "For a list of additional addons and tools usable with sway please"
+ einfo "visit the offical wiki at:"
+ einfo "https://github.com/swaywm/sway/wiki/Useful-add-ons-for-sway"
+ einfo "Please note that some of them might not (yet) available on gentoo"
+}
diff --git a/gui-wm/sway/sway-9999.ebuild b/gui-wm/sway/sway-9999.ebuild
index a84e8282f192..8468aba7acc3 100644
--- a/gui-wm/sway/sway-9999.ebuild
+++ b/gui-wm/sway/sway-9999.ebuild
@@ -24,7 +24,7 @@ IUSE="grimshot +man +swaybar +swaynag tray wallpapers X"
DEPEND="
>=dev-libs/json-c-0.13:0=
- >=dev-libs/libinput-1.6.0:0=
+ >=dev-libs/libinput-1.21.0:0=
sys-auth/seatd:=
dev-libs/libpcre2
>=dev-libs/wayland-1.20.0
@@ -32,6 +32,7 @@ DEPEND="
x11-libs/libxkbcommon
x11-libs/pango
x11-libs/pixman
+ x11-libs/xcb-util-wm
media-libs/mesa[gles2,libglvnd(+)]
swaybar? ( x11-libs/gdk-pixbuf:2 )
tray? ( || (
@@ -42,6 +43,7 @@ DEPEND="
wallpapers? ( gui-apps/swaybg[gdk-pixbuf(+)] )
X? ( x11-libs/libxcb:0= )
"
+# x11-libs/xcb-util-wm needed for xcb-iccm
if [[ ${PV} == 9999 ]]; then
DEPEND+="~gui-libs/wlroots-9999:=[X?]"
else