summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Roy <julien@jroy.ca>2024-05-13 11:48:52 -0400
committerYixun Lan <dlan@gentoo.org>2024-05-15 08:03:38 +0000
commitb790d30d79790b2976162b9712b30c8d507b6a0a (patch)
tree374c075b72ef9ade214aa8113436c8946950ac96 /gui-libs
parentdev-util/hyprwayland-scanner: add 0.3.7 (diff)
downloadgentoo-b790d30d79790b2976162b9712b30c8d507b6a0a.tar.gz
gentoo-b790d30d79790b2976162b9712b30c8d507b6a0a.tar.bz2
gentoo-b790d30d79790b2976162b9712b30c8d507b6a0a.zip
gui-libs/hyprcursor: add 0.1.8
Signed-off-by: Julien Roy <julien@jroy.ca> Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'gui-libs')
-rw-r--r--gui-libs/hyprcursor/Manifest1
-rw-r--r--gui-libs/hyprcursor/hyprcursor-0.1.8.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/gui-libs/hyprcursor/Manifest b/gui-libs/hyprcursor/Manifest
index ffc487218689..da5ac8058eb1 100644
--- a/gui-libs/hyprcursor/Manifest
+++ b/gui-libs/hyprcursor/Manifest
@@ -1,2 +1,3 @@
DIST hyprcursor-0.1.5.gh.tar.gz 20096 BLAKE2B 31595ca4ffb0e9683d2584dc1e58483435bd19180a4326d741b4093d780b79878e9202153744b54786ed82991469ddd277112a79b3a3a95179195519cdfe9ff9 SHA512 3092b6773a34fa1cab10f83fa48274d79a50cd373dfe8a89d0170a78767a66b5e0cbe57cd1b86bc4bb85371c23ac7425f59e61fb50723a895fef4e7f6039fdfc
DIST hyprcursor-0.1.7.gh.tar.gz 25670 BLAKE2B 72b4e7a78b832782c2a79e59eadf7e3d94d14377291f3cffd38d59d11ca119eca3ba1febdd36535a16ce6f15c02804f9fe6291ac2d5758cde51090929b17635d SHA512 dd506860fc7a0d5b1f9602330becc7f9a37fda19d92fcc10150e6e23680124d63451b98a92e33b9a820db385fdba29a7f306d0c1639426aa06c749fa1dfad04e
+DIST hyprcursor-0.1.8.gh.tar.gz 25946 BLAKE2B 7f3186f6447553664cf2a2af43426a89f0d64ad05b191720447116e25a22ae562805cd2aa1786a0a40dfa4cbb10629e9cbf1a3def7f0018c3c7680e6346fc0f5 SHA512 f03ead33b37d46f189ec16b6dcebf066a4f531e74a5a71c4aaae90cb09415fd3901793bcdf41d7ce7bd2b5a22856abda360ed63648a19f4aef40dc78ae96963e
diff --git a/gui-libs/hyprcursor/hyprcursor-0.1.8.ebuild b/gui-libs/hyprcursor/hyprcursor-0.1.8.ebuild
new file mode 100644
index 000000000000..49f4d5143574
--- /dev/null
+++ b/gui-libs/hyprcursor/hyprcursor-0.1.8.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="The hyprland cursor format, library and utilities"
+HOMEPAGE="https://github.com/hyprwm/hyprcursor"
+SRC_URI="https://github.com/hyprwm/hyprcursor/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+
+# Disable tests since as per upstream, tests require a theme to be installed
+# See also https://github.com/hyprwm/hyprcursor/commit/94361fd8a75178b92c4bb24dcd8c7fac8423acf3
+RESTRICT="test"
+
+RDEPEND="
+ dev-cpp/tomlplusplus
+ >=dev-libs/hyprlang-0.4.2
+ dev-libs/libzip
+ gnome-base/librsvg:2
+ x11-libs/cairo
+"