summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeonardo Hernández Hernández <leohdz172@proton.me>2024-06-06 12:14:26 -0600
committerArthur Zamarin <arthurzam@gentoo.org>2024-06-11 08:34:15 +0300
commitb194e0e9d0a5d9eb6b83d101ca710fd0e9c457f0 (patch)
tree7e9c93ee0a6e156db00e69d8f1c95aeb32508ecc /gui-libs
parentapp-arch/7zip: fix makefile mkdir race (diff)
downloadgentoo-b194e0e9d0a5d9eb6b83d101ca710fd0e9c457f0.tar.gz
gentoo-b194e0e9d0a5d9eb6b83d101ca710fd0e9c457f0.tar.bz2
gentoo-b194e0e9d0a5d9eb6b83d101ca710fd0e9c457f0.zip
gui-libs/wlroots: fix automagic of lcms
Signed-off-by: Leonardo Hernández Hernández <leohdz172@proton.me> Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'gui-libs')
-rw-r--r--gui-libs/wlroots/wlroots-9999.ebuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/gui-libs/wlroots/wlroots-9999.ebuild b/gui-libs/wlroots/wlroots-9999.ebuild
index 77c372411845..e2f9010afd44 100644
--- a/gui-libs/wlroots/wlroots-9999.ebuild
+++ b/gui-libs/wlroots/wlroots-9999.ebuild
@@ -19,7 +19,7 @@ else
fi
LICENSE="MIT"
-IUSE="liftoff +libinput +drm +session tinywl vulkan x11-backend xcb-errors X"
+IUSE="liftoff +libinput +drm +session tinywl lcms vulkan x11-backend xcb-errors X"
REQUIRED_USE="
drm? ( session )
libinput? ( session )
@@ -41,6 +41,7 @@ DEPEND="
sys-apps/hwdata
liftoff? ( >=dev-libs/libliftoff-0.4 )
)
+ lcms? ( media-libs/lcms:2 )
libinput? ( >=dev-libs/libinput-1.14.0:= )
session? (
sys-auth/seatd:=
@@ -85,6 +86,7 @@ src_configure() {
$(meson_feature X xwayland)
-Dbackends=${meson_backends}
$(meson_feature session)
+ $(meson_feature lcms color-management)
)
meson_src_configure