summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2023-03-05 12:09:24 -0500
committerMatt Turner <mattst88@gentoo.org>2023-03-05 12:09:24 -0500
commita4f0a45dc3e0a3f35bd789f24636d06c4ebb9948 (patch)
treebe30d49a338b7153f73d37bb5f5d126f216f326f /gui-libs
parentx11-wm/page: Drop outdated use-dependencies (diff)
downloadgentoo-a4f0a45dc3e0a3f35bd789f24636d06c4ebb9948.tar.gz
gentoo-a4f0a45dc3e0a3f35bd789f24636d06c4ebb9948.tar.bz2
gentoo-a4f0a45dc3e0a3f35bd789f24636d06c4ebb9948.zip
gui-libs/wpebackend-fdo: Version bump to 1.14.1
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'gui-libs')
-rw-r--r--gui-libs/wpebackend-fdo/Manifest1
-rw-r--r--gui-libs/wpebackend-fdo/wpebackend-fdo-1.14.1.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/gui-libs/wpebackend-fdo/Manifest b/gui-libs/wpebackend-fdo/Manifest
index 30c790306628..f69bf200f6a2 100644
--- a/gui-libs/wpebackend-fdo/Manifest
+++ b/gui-libs/wpebackend-fdo/Manifest
@@ -1 +1,2 @@
DIST wpebackend-fdo-1.14.0.tar.xz 43068 BLAKE2B e5b06e7313a0122578fd668cb17a0f28e8f67ba4831b80616979ebedf15ee4fde94f610b5c7e4831ce90c51e11573ff8fc8f4970237230f5d3184b8aead21ce6 SHA512 9eda873adda854e1e498236215b7e240076caca52adca4f60277fb26db8ae9e6436b27a9b25ebf95612835acad82b764ccd21d8ae997e8802665dd79251083d6
+DIST wpebackend-fdo-1.14.1.tar.xz 43188 BLAKE2B e4e2ae5da7ca93847644e5f6cbb97251f394ab6237b59868e727e89ea57f8676c8319a7a944a4b5080161187d6b5c6937af3913976f215ceb99b42b5fe86c5c0 SHA512 711ffa968852818f080dbb2b222168b61d0d20584b6022e309be7f1a06128440c91d30e61673a30f89831aba4b30dbc0cdae560b3d5f6c8ac462b5445a4c9e8b
diff --git a/gui-libs/wpebackend-fdo/wpebackend-fdo-1.14.1.ebuild b/gui-libs/wpebackend-fdo/wpebackend-fdo-1.14.1.ebuild
new file mode 100644
index 000000000000..a831404745c4
--- /dev/null
+++ b/gui-libs/wpebackend-fdo/wpebackend-fdo-1.14.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="WPE backend designed for Linux desktop systems"
+HOMEPAGE="https://wpewebkit.org/"
+SRC_URI="https://wpewebkit.org/releases/${P}.tar.xz"
+
+LICENSE="BSD-2"
+SLOT="1.0"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ media-libs/libepoxy[egl]
+ dev-libs/glib:2
+ >=dev-libs/wayland-1.10
+ >=gui-libs/libwpe-1.6:1.0
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/wayland-scanner
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local emesonargs=(
+ -Dbuild_docs=false # hotdoc not packaged
+ )
+
+ meson_src_configure
+}