summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2024-05-31 20:22:16 -0300
committerPacho Ramos <pacho@gentoo.org>2024-07-19 10:22:45 +0200
commit113c092b726709ee2ba52a6547d384df0f1726de (patch)
treeb6bc163581e3b5776184f26101cb1aa446f132f9 /gui-libs
parentdev-util/nvidia-cuda-toolkit: add 12.5.1 (diff)
downloadgentoo-113c092b726709ee2ba52a6547d384df0f1726de.tar.gz
gentoo-113c092b726709ee2ba52a6547d384df0f1726de.tar.bz2
gentoo-113c092b726709ee2ba52a6547d384df0f1726de.zip
gui-libs/gtksourceview: Bump to 5.12.1
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/34773 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'gui-libs')
-rw-r--r--gui-libs/gtksourceview/Manifest1
-rw-r--r--gui-libs/gtksourceview/gtksourceview-5.12.1.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/gui-libs/gtksourceview/Manifest b/gui-libs/gtksourceview/Manifest
index 049dc835b63a..0fc457c1606c 100644
--- a/gui-libs/gtksourceview/Manifest
+++ b/gui-libs/gtksourceview/Manifest
@@ -1 +1,2 @@
DIST gtksourceview-5.10.0.tar.xz 1255564 BLAKE2B a105d118716f8e61beb4bb17b8e64dacdc42f1fcfac805a9b517431a4db4da92aea82ba7b042556bc222d8a6406cbe00281c5513c6e55b7517048dae17cf83a5 SHA512 c8fb377c0f65fff35fe764c98d40a399b2f3982bfb7e25512b50f4f3c31b226d4775e136fc4be682b2e44a3b643cefd01d195c9a61f5c3ca81d15bef0093e47a
+DIST gtksourceview-5.12.1.tar.xz 1265500 BLAKE2B a9200d97cda514c62a181e3d07a0c71719710299d06e1cbc29c6b7817eb6167e7b7bdc64f32121fc54bd7093a918600c0fba70b5cb4b93906f6aaf80fd6521ed SHA512 64c347df505c640feb2d5885a3fa047a3a5dc6bf86b031ec9f8eec5544bc9d996ca3bfd41aea78ebfa9171a206a64d88773d53f1bc8d0f2171429c1ee788cd40
diff --git a/gui-libs/gtksourceview/gtksourceview-5.12.1.ebuild b/gui-libs/gtksourceview/gtksourceview-5.12.1.ebuild
new file mode 100644
index 000000000000..963384d48830
--- /dev/null
+++ b/gui-libs/gtksourceview/gtksourceview-5.12.1.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org meson vala virtualx xdg
+
+DESCRIPTION="A text widget implementing syntax highlighting and other features"
+HOMEPAGE="https://wiki.gnome.org/Projects/GtkSourceView"
+
+LICENSE="LGPL-2.1+"
+SLOT="5"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="gtk-doc +introspection sysprof +vala"
+REQUIRED_USE="
+ gtk-doc? ( introspection )
+ vala? ( introspection )
+"
+
+RDEPEND="
+ >=dev-libs/glib-2.72:2
+ >=gui-libs/gtk-4.6:4[introspection?]
+ >=dev-libs/libxml2-2.6:2
+ introspection? ( >=dev-libs/gobject-introspection-1.70.0:= )
+ >=dev-libs/fribidi-0.19.7
+ media-libs/fontconfig
+ x11-libs/pango[introspection?]
+ >=dev-libs/libpcre2-10.21:=[-recursion-limit(-)]
+ sysprof? ( dev-util/sysprof-capture:4 )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/glib-utils
+ gtk-doc? ( dev-util/gi-docgen )
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )
+"
+
+src_prepare() {
+ default
+ use vala && vala_setup
+ xdg_environment_reset
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dinstall-tests=false
+ $(meson_feature introspection)
+ $(meson_use vala vapi)
+ $(meson_use gtk-doc documentation)
+ $(meson_use sysprof)
+ )
+ meson_src_configure
+}
+
+src_test() {
+ # Tests fail in test-regex with libpcre2[recursion-limit] - https://gitlab.gnome.org/GNOME/gtksourceview/-/issues/255
+ # Ensured OK via USE dep, as it would mean issues in real usage for syntax highlighting as well
+ virtx meson_src_test --timeout-multiplier=5
+}
+
+src_install() {
+ meson_src_install
+
+ insinto /usr/share/${PN}-5/language-specs
+ newins "${FILESDIR}"/5-gentoo.lang gentoo.lang
+
+ if use gtk-doc ; then
+ mkdir -p "${ED}"/usr/share/gtk-doc/html/ || die
+ mv "${ED}"/usr/share/doc/${PN}${SLOT} "${ED}"/usr/share/gtk-doc/html/ || die
+ fi
+}