summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAisha Tammy <aisha@bsd.ac>2023-02-24 16:38:13 -0500
committerSam James <sam@gentoo.org>2023-03-11 17:04:06 +0000
commit1639fd9e5b6f15fc4a4f77be5f4044a48e34e1f4 (patch)
tree8d6500bd49d19cbdf28694827c76ea4d57b4dcd0 /gui-apps
parentdev-libs/weston: move wayland-protocols to DEPEND only (diff)
downloadgentoo-1639fd9e5b6f15fc4a4f77be5f4044a48e34e1f4.tar.gz
gentoo-1639fd9e5b6f15fc4a4f77be5f4044a48e34e1f4.tar.bz2
gentoo-1639fd9e5b6f15fc4a4f77be5f4044a48e34e1f4.zip
gui-apps/mako: wayland-scanner/protocol BDEPEND/DEPEND fixes
Signed-off-by: Aisha Tammy <aisha@bsd.ac> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'gui-apps')
-rw-r--r--gui-apps/mako/mako-1.7.1-r1.ebuild12
-rw-r--r--gui-apps/mako/mako-9999.ebuild25
2 files changed, 23 insertions, 14 deletions
diff --git a/gui-apps/mako/mako-1.7.1-r1.ebuild b/gui-apps/mako/mako-1.7.1-r1.ebuild
index 6ffde2623461..13a9eb711c00 100644
--- a/gui-apps/mako/mako-1.7.1-r1.ebuild
+++ b/gui-apps/mako/mako-1.7.1-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -20,9 +20,8 @@ LICENSE="MIT"
SLOT="0"
IUSE="elogind +icons systemd"
-DEPEND="
+RDEPEND="
dev-libs/wayland
- dev-util/wayland-scanner
x11-libs/pango
x11-libs/cairo
|| (
@@ -36,13 +35,14 @@ DEPEND="
x11-libs/gdk-pixbuf
)
"
-RDEPEND="
- ${DEPEND}
+DEPEND="
+ ${RDEPEND}
>=dev-libs/wayland-protocols-1.21
"
BDEPEND="
- virtual/pkgconfig
app-text/scdoc
+ dev-util/wayland-scanner
+ virtual/pkgconfig
"
src_configure() {
diff --git a/gui-apps/mako/mako-9999.ebuild b/gui-apps/mako/mako-9999.ebuild
index a92179a0efdb..13a9eb711c00 100644
--- a/gui-apps/mako/mako-9999.ebuild
+++ b/gui-apps/mako/mako-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-inherit meson
+inherit meson systemd
DESCRIPTION="A lightweight notification daemon for Wayland. Works on Sway"
HOMEPAGE="https://github.com/emersion/mako"
@@ -20,9 +20,8 @@ LICENSE="MIT"
SLOT="0"
IUSE="elogind +icons systemd"
-DEPEND="
+RDEPEND="
dev-libs/wayland
- dev-util/wayland-scanner
x11-libs/pango
x11-libs/cairo
|| (
@@ -36,18 +35,22 @@ DEPEND="
x11-libs/gdk-pixbuf
)
"
-RDEPEND="
- ${DEPEND}
+DEPEND="
+ ${RDEPEND}
>=dev-libs/wayland-protocols-1.21
"
BDEPEND="
- virtual/pkgconfig
app-text/scdoc
+ dev-util/wayland-scanner
+ virtual/pkgconfig
"
src_configure() {
local emesonargs=(
-Dicons=$(usex icons enabled disabled)
+ -Dzsh-completions=true
+ -Dfish-completions=true
+ -Dbash-completions=true
)
if use systemd ; then
@@ -60,3 +63,9 @@ src_configure() {
meson_src_configure
}
+
+src_install() {
+ meson_src_install
+
+ systemd_douserunit contrib/systemd/mako.service
+}