summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2024-04-03 18:02:30 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2024-04-03 18:03:01 +0200
commitc21cb39e53a74ba01e78a387e6a048e6826988f5 (patch)
tree5ee74dbce007e3d10a444f16e0cd2859879823c7 /gnustep-base
parentdev-python/vpython: bump to 7.6.5 (diff)
downloadgentoo-c21cb39e53a74ba01e78a387e6a048e6826988f5.tar.gz
gentoo-c21cb39e53a74ba01e78a387e6a048e6826988f5.tar.bz2
gentoo-c21cb39e53a74ba01e78a387e6a048e6826988f5.zip
gnustep-base/gnustep-gui: giflib is a hard dependency
Closes: https://bugs.gentoo.org/927743 Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'gnustep-base')
-rw-r--r--gnustep-base/gnustep-gui/gnustep-gui-0.29.0-r2.ebuild (renamed from gnustep-base/gnustep-gui/gnustep-gui-0.29.0-r1.ebuild)13
-rw-r--r--gnustep-base/gnustep-gui/gnustep-gui-0.30.0-r2.ebuild (renamed from gnustep-base/gnustep-gui/gnustep-gui-0.30.0-r1.ebuild)13
2 files changed, 10 insertions, 16 deletions
diff --git a/gnustep-base/gnustep-gui/gnustep-gui-0.29.0-r1.ebuild b/gnustep-base/gnustep-gui/gnustep-gui-0.29.0-r2.ebuild
index 2f19d72bcb7b..68d961c1b3f3 100644
--- a/gnustep-base/gnustep-gui/gnustep-gui-0.29.0-r1.ebuild
+++ b/gnustep-base/gnustep-gui/gnustep-gui-0.29.0-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -11,16 +11,16 @@ SRC_URI="ftp://ftp.gnustep.org/pub/gnustep/core/${P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~alpha amd64 ppc sparc x86 ~amd64-linux ~x86-linux"
-IUSE="cups gif icu jpeg png speech"
+IUSE="cups icu jpeg png speech"
DEPEND="${GNUSTEP_CORE_DEPEND}
app-text/aspell
>=gnustep-base/gnustep-base-1.28.0:=[icu?]
media-libs/audiofile
+ >=media-libs/giflib-4.1:=
>=media-libs/tiff-3:=
x11-libs/libXt
cups? ( >=net-print/cups-1.7.4:= )
- gif? ( >=media-libs/giflib-4.1:= )
icu? ( dev-libs/icu:= )
jpeg? ( media-libs/libjpeg-turbo:= )
png? ( >=media-libs/libpng-1.2:= )
@@ -40,18 +40,15 @@ src_prepare() {
src_configure() {
egnustep_env
- local myconf=
- use gif && myconf="--disable-ungif --enable-libgif"
-
econf \
$(use_enable cups) \
$(use_enable icu) \
$(use_enable jpeg) \
$(use_enable png) \
$(use_enable speech) \
+ --disable-ungif --enable-libgif \
--with-tiff-include="${EPREFIX}"/usr/include \
- --with-tiff-library="${EPREFIX}"/usr/$(get_libdir) \
- ${myconf}
+ --with-tiff-library="${EPREFIX}"/usr/$(get_libdir)
}
src_test() {
diff --git a/gnustep-base/gnustep-gui/gnustep-gui-0.30.0-r1.ebuild b/gnustep-base/gnustep-gui/gnustep-gui-0.30.0-r2.ebuild
index 266a0fd9a8f9..8e05ac1920b1 100644
--- a/gnustep-base/gnustep-gui/gnustep-gui-0.30.0-r1.ebuild
+++ b/gnustep-base/gnustep-gui/gnustep-gui-0.30.0-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -11,16 +11,16 @@ SRC_URI="ftp://ftp.gnustep.org/pub/gnustep/core/${P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux"
-IUSE="cups gif icu jpeg png speech"
+IUSE="cups icu jpeg png speech"
DEPEND="${GNUSTEP_CORE_DEPEND}
app-text/aspell
>=gnustep-base/gnustep-base-1.28.0:=[icu?]
media-libs/audiofile
+ >=media-libs/giflib-4.1:=
>=media-libs/tiff-3:=
x11-libs/libXt
cups? ( >=net-print/cups-1.7.4:= )
- gif? ( >=media-libs/giflib-4.1:= )
icu? ( dev-libs/icu:= )
jpeg? ( media-libs/libjpeg-turbo:= )
png? ( >=media-libs/libpng-1.2:= )
@@ -42,18 +42,15 @@ src_prepare() {
src_configure() {
egnustep_env
- local myconf=
- use gif && myconf="--disable-ungif --enable-libgif"
-
econf \
$(use_enable cups) \
$(use_enable icu) \
$(use_enable jpeg) \
$(use_enable png) \
$(use_enable speech) \
+ --disable-ungif --enable-libgif \
--with-tiff-include="${EPREFIX}"/usr/include \
- --with-tiff-library="${EPREFIX}"/usr/$(get_libdir) \
- ${myconf}
+ --with-tiff-library="${EPREFIX}"/usr/$(get_libdir)
}
src_test() {